Project

General

Profile

Bug #17442

tails-bugs@ needs to get its expiry date pushed back

Added by CyrilBrulebois 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Infrastructure
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Since yesterday, the stable branch exhibits a new failure in its test suite:

cucumber features/keys.feature:4 # Scenario: The shipped Tails OpenPGP keys are up-to-date

Looking at the shipped keys, one can see those set to expire in 2020:

  • tails-bugs@: 2020-04-14 → this is the one that triggers the error
  • tails@: 2020-10-07 → this could become a similar issue in 6 months

(Others don't expire or expire in 2021, so are not an immediate issue.)

Not entirely sure who to assign this to. Tentatively picking the help desk, who should know?


Related issues

Blocks Tails - Feature #13242: Core work: Sysadmin (Maintain our already existing services) Confirmed 06/29/2017

Associated revisions

Revision 69a48c8f (diff)
Added by intrigeri about 2 months ago

Update expiration date of the OpenPGP public key (Closes: #17442)

History

#1 Updated by emmapeel 3 months ago

we never updated it yet, in frontdesk. not sure how to go about that... maybe there is a set of rules for updating expiration dates?

#2 Updated by intrigeri 2 months ago

  • Assignee changed from Help Desk to zen
  • Target version set to Tails_4.3

we never updated it yet, in frontdesk.

This is usually handled by our sysadmins, who host the last and maintain its private key (the fact list subscribers also have that private key is a side-effect of Schleuder bugs rather than an expression of a maintenance role) ⇒ assigning to the sysadmin who was on duty on Jan 16, and still is :)

#3 Updated by intrigeri 2 months ago

(Just a poke to ensure zen gets a notification email about this :)

#4 Updated by intrigeri about 2 months ago

  • Blocks Feature #13242: Core work: Sysadmin (Maintain our already existing services) added

#5 Updated by intrigeri about 2 months ago

  • Assignee changed from zen to intrigeri
  • Priority changed from Normal to Elevated

This problem has forced developers to filter out the corresponding test suite failure every time they analyze Jenkins results since almost 3 weeks, so I'd like this to be resolved soon ⇒ will give it a try :)

#6 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF