Project

General

Profile

Feature #17440

Feature #8415: Migrate from aufs to overlayfs

Create overlayfs-based IUKs v2 for the test suite

Added by intrigeri 3 months ago. Updated 14 days ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
feature/8415-overlayfs+force-all-tests, master
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 7b5f74c5 (diff)
Added by intrigeri about 1 month ago

Test suite: adjust create-test-iuks for overlayfs version numbers (refs: #17440)

For a while we'll have 2 kinds of:

- IUKs v2 on the download mirrors
- UDFs v2 on our website

i.e. one set based on aufs, the other set based on overlayfs.

They are differentiated by having their version number end with ~test vs.
~testoverlayfs, which yields different filenames.

Revision b7eb472a (diff)
Added by intrigeri about 1 month ago

Add test UDFs v2 based on overlayfs (refs: #17440)

Revision 11a1d437 (diff)
Added by intrigeri about 1 month ago

Fix test UDFs v2 based on overlayfs (refs: #17440)

Revision 482a5c57 (diff)
Added by intrigeri about 1 month ago

Test suite: update reference images for overlayfs (refs: #17440)

Revision c5b48c9f (diff)
Added by intrigeri about 1 month ago

Test suite: sync create-test-iuks script to include the expected changes (refs: #17440)

Revision 3af71558 (diff)
Added by intrigeri about 1 month ago

Fix test UDFs v2 based on overlayfs (refs: #17440)

History

#1 Updated by intrigeri 3 months ago

  • Priority changed from Elevated to High

#2 Updated by intrigeri about 2 months ago

#3 Updated by intrigeri about 2 months ago

  • Target version changed from Tails_4.3 to Tails_4.4

#4 Updated by intrigeri about 1 month ago

  • Subject changed from Create overlayfs-base IUKs v2 for the test suite to Create overlayfs-based IUKs v2 for the test suite

#5 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress

#6 Updated by intrigeri about 1 month ago

  • Feature Branch set to feature/8415-overlayfs+force-all-tests, master

Uploaded IUKs v2, waiting for mirrors to sync.

Added UDFs v2 to our website with b7eb472ad6ff02def5410ec02840db61c09e4454.

#7 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault

The automatic upgrade test scenarios now pass here!

#8 Updated by intrigeri about 1 month ago

(As per timeline discussion we had yesterday. This is about finishing the work, and possibly merging it into devel, not about merging it into stable yet: the current plan is to release this in 4.5, not 4.4.)

#9 Updated by intrigeri about 1 month ago

Gah, I documented a no-op change, ah ah. Sorry for the noise.

#10 Updated by segfault 25 days ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (segfault)

#11 Updated by CyrilBrulebois 19 days ago

FYI: Ticket metadata is slightly confusing, as it seems to be resolved in Tails 4.4, which it isn't? (Currently checking debian/changelog vs. the “Completed for the next release” view, this pops up.)

#12 Updated by intrigeri 19 days ago

hi @CyrilBrulebois,

FYI: Ticket metadata is slightly confusing, as it seems to be resolved in Tails 4.4, which it isn't? (Currently checking debian/changelog vs. the “Completed for the next release” view, this pops up.)

I see.

Technically, we did create overlayfs-based IUKs v2 for the test suite. But it's true that it's orthogonal to 4.4.

To track progress on larger projects, we often close individual subtasks as resolved as soon as they've been completed.
I understand that the "Target version" can thus get confusing.

I believe that with GitLab, this problem will occur less often, because it has no child issue support but it has "list of tasks" (checklist) support. But still, I think it'll still happen occasionally. To avoid that entirely, I think we would need to take a step back and rethink how we track projects. I'd like to come back to this after we've spent 6+ months on GitLab and have data about how it'll impact our workflows in practice (there's only so much we can guess before we actually start using this new tool). Fair enough?

If you think that's important enough to warrant making sure we don't forget about it, let me know and I'll give myself a ticket!

#13 Updated by CyrilBrulebois 17 days ago

Hey @intrigeri!

Thanks for the explanation, it makes a lot of sense.

I really don't mind the current setup/workflow; I was just a little surprised, possibly because I didn't encounter this situation before (or maybe there was a bigger list of issues and I missed similar tickets). That's why I did mention it in passing, just making sure I wasn't misunderstanding something.

All in all: keep doing what's best/customary to keep track of things; now I know that such things can happen and that it's not an issue (on my side, at least). :)

#14 Updated by intrigeri 14 days ago

  • % Done changed from 0 to 100

Also available in: Atom PDF