Project

General

Profile

Bug #17388

RTL8101 ethernet chipset doesn't work anymore since Tails 4.1.1

Added by goupille 3 months ago. Updated 4 days ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

several users reported that since tails 4.1.1 the ethernet connectiosn are failing with the following error message:

Authentication failed: Connection to the network failed

the affected adapter is a

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)

20200201_191724.jpg View (1.8 MB) intrigeri, 02/04/2020 11:39 AM


Related issues

Related to Tails - Bug #17430: No network unless MAC spoofing is disabled with Intel I210 Gigabit Confirmed
Related to Tails - Bug #17320: Kernel Panic with some Macbook Pro Resolved
Related to Tails - Bug #17418: MAC spoofing break RTL8192EE since tails 4.2 Confirmed
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by intrigeri 3 months ago

  • Category set to Hardware support
  • Assignee changed from intrigeri to goupille

Hi @goupille,

several users reported that since tails 4.1.1 the ethernet connectiosn are failing with the following error message:

> Authentication failed: Connection to the network failed
> 

For the avoidance of doubt, could you please confirm that this problem does not occur with Tails 4.1?

How and where is that error message displayed?

Any chance I can see the corresponding logs?

#2 Updated by goupille 3 months ago

it seems that the user can see the same issue on a different computer so I suspect an issue with the Tails device instead, I asked them to try a fresh install on a brand new stick...

#3 Updated by goupille 3 months ago

  • Status changed from New to Rejected
  • Assignee deleted (goupille)

according to the user the issue is not here anymore after a fresh install of Tails 4.1.1 on a brand new USB stick, hence I reject this ticket...

#4 Updated by goupille 3 months ago

  • Status changed from Rejected to New

as a matter of fact the user came back with the same issue so I re-open this ticket.

#5 Updated by goupille 3 months ago

intrigeri wrote:

For the avoidance of doubt, could you please confirm that this problem does not occur with Tails 4.1?

yes it is confirmed that 4.1 was the latest version of Tails without this problem occuring

#6 Updated by goupille 3 months ago

  • Assignee set to intrigeri

#7 Updated by intrigeri 2 months ago

#8 Updated by intrigeri 2 months ago

  • Related to Bug #17430: No network unless MAC spoofing is disabled with Intel I210 Gigabit added

#9 Updated by intrigeri 2 months ago

  • Related to Bug #17320: Kernel Panic with some Macbook Pro added

#10 Updated by intrigeri 2 months ago

  • Related to Bug #17418: MAC spoofing break RTL8192EE since tails 4.2 added

#11 Updated by intrigeri 2 months ago

  • Status changed from New to Confirmed
  • Assignee deleted (intrigeri)

Thanks. The only relevant change in the release that introduced this problem (4.1.1) is the fix for #17320, which I guess is the explanation.

I'm a bit swamped in backlog so dear help desk: do you remember, off the top of your head, if 4.1.1 introduced any other regression wrt. networking hardware support, apart of #17430 and #17418?

Could I please get the output of /sbin/lsmod:

  • run from Tails 4.1
  • run from Tails 4.1.1 or newer

?

#12 Updated by intrigeri 2 months ago

  • Assignee set to goupille

#13 Updated by intrigeri about 2 months ago

Adding possibly related (thanks kibi) screenshot.

#14 Updated by intrigeri 25 days ago

The errors on kibi's screenshot look like kernel: r8169: Unknown symbol phy_set_max_speed (err -2). That missing symbol is exported from drivers/net/phy/phy-core.c. I very much suspect that something along these lines is happening:

  1. config/chroot_local-includes/etc/initramfs-tools/hooks/mac-boot-hack ensures our initramfs does not include the module that ships this code
  2. When we do our "block loading all network drivers and then unblock them after the Greeter" dance, the kernel or udev fails to load everything it should, or to update its knowledge of available symbols.
  3. As a result, network drivers like r8169 and btintel don't work properly.

#15 Updated by intrigeri 25 days ago

  • Related to Bug #17499: AC 9560 Wifi doesn't work in 4.3 added

#16 Updated by intrigeri 25 days ago

goupille, ping?
Any chance we get the info we need here or on #17430?

Besides, if we prepared an experimental image (that reverts the workaround introduced in Tails 4.1.1), do you think you could get affected users to test it?

#17 Updated by goupille 25 days ago

the user I asked for those tests said that they were ok with the "disabling mac spoofing" workaround and did not seem very willing to take too much time to test things. they didn't have the requested image (4.1) anymore and weren't comfortable downloading an outdated image from bittorrent...
maybe I can ask still them to try an experimental image, though...

#18 Updated by intrigeri 11 days ago

  • Assignee changed from goupille to intrigeri
  • Target version set to Tails_4.6

the user I asked for those tests said that they were ok with the "disabling mac spoofing" workaround and did not seem very willing to take too much time to test things. they didn't have the requested image (4.1) anymore and weren't comfortable downloading an outdated image from bittorrent...
maybe I can ask still them to try an experimental image, though...

OK, let's try this then. IMO it's worth preparing such an image anyway, so it's handy whenever someone else report similar issues about network cards having stopped working in the last months.

#19 Updated by intrigeri 7 days ago

  • Related to deleted (Bug #17499: AC 9560 Wifi doesn't work in 4.3)

#20 Updated by CyrilBrulebois 7 days ago

For those who care about this topic, it seems a new feature branch appeared today: bugfix/17388-17418-17430-re-add-net-drivers-to-initramfs

#21 Updated by intrigeri 4 days ago

  • Assignee changed from intrigeri to numbat

I've just emailed help desk, asking them to gather feedback about https://nightly.tails.boum.org/build_Tails_ISO_bugfix-17388-17418-17430-re-add-net-drivers-to-initramfs/lastSuccessful/archive/build-artifacts/ from affected users ⇒ reassigning to the help desk person currently on duty.

Also available in: Atom PDF