Project

General

Profile

Feature #17385

Grow /home on rsync.lizard

Added by intrigeri 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

Once #15287 is done, at some point in our release process, rsync.lizard:/home will need to store all the IUKs to the version to be released.
The number of such IUKs and the corresponding disk space will grow over time during the 4.x cycle, then go down to 0 when 5.0 is released, then grow over time during the 5.x cycle, etc.
Let's be prepared for the worst case scenario ASAP, so this does not end up blocking a release :)


Related issues

Related to Tails - Feature #15287: Make it possible to reproducibly generate IUKs in CI Resolved 02/05/2018
Related to Tails - Feature #17412: Drop the need for dedicated temporary storage space for IUKs on rsync.lizard Resolved
Blocks Tails - Feature #13242: Core work: Sysadmin (Maintain our already existing services) Confirmed 06/29/2017

History

#1 Updated by intrigeri 3 months ago

  • Related to Feature #15287: Make it possible to reproducibly generate IUKs in CI added

#2 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress

We're currently using /home as a temporary place where we download and verify IUKs, before moving them to /srv. That's not ideal because it means we need to allocate the corresponding disk space twice. So here's my plan:

  1. Today, create a new LV for /home and migrate existing data to it: it's the cheapest short-term way to ensure this problem does not block 4.2.1.
  2. Later, make it so temporary data is stored directly in /srv during the release process. One idea could be to:
    1. give every RM permission to SSH into rsync.lizard as the rsync_tails user, and point $HOME for this user somewhere under /srv
    2. adjust the release process so that all SSH operations done on rsync.lizard are done as the rsync_tails user
    3. drop the /home LV and migrate the corresponding data back to /

#3 Updated by intrigeri 3 months ago

  • Blocks Feature #13242: Core work: Sysadmin (Maintain our already existing services) added

#4 Updated by intrigeri 3 months ago

  • Target version changed from Tails_4.3 to Tails_4.2.2

#5 Updated by intrigeri 3 months ago

  • Related to Feature #17412: Drop the need for dedicated temporary storage space for IUKs on rsync.lizard added

#6 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)

Step 1 completed, created #17412 for step 2.

Also available in: Atom PDF