Project

General

Profile

Bug #17384

devel branch FTBFS since linux-image-5.4.0-1-amd64 replaced linux-image-5.3.0-3-amd64 in sid

Added by intrigeri 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
feature/17384-17443-linux-5.4+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The cheapest temporary mitigation is probably to install the kernel from testing instead of sid.
But if we have time to instead handle the upgrade to Linux 5.4, that would be a better investment.


Related issues

Related to Tails - Feature #17443: Upgrade Linux to 5.4.8+ Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 0afd359c (diff)
Added by intrigeri 2 months ago

Update Linux kernel to linux-image-5.4.0-3-amd64, currently at 5.4.13-1, and aufs to 5.4.3 20200127 (refs: #17384, #17443)

Revision db622338 (diff)
Added by intrigeri about 2 months ago

Update Linux kernel to linux-image-5.4.0-3-amd64, currently at 5.4.13-1, and aufs to 5.4.3 20200127 (refs: #17384, #17443)

Revision a8cedbd3
Added by anonym about 2 months ago

Merge remote-tracking branch 'origin/feature/17384-17443-linux-5.4-for-stable+force-all-tests' into stable

Fix-committed: #17384

History

#1 Updated by intrigeri 3 months ago

#2 Updated by segfault 2 months ago

#3 Updated by intrigeri 2 months ago

  • Assignee set to intrigeri

I'll give it a shot.

#4 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by intrigeri 2 months ago

  • Feature Branch set to feature/17384-17443-linux-5.4+force-all-tests

#6 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)

I've mistakenly reported about the checklist and test results on #17443, so see that ticket for more info. Please review'n'merge this into devel; #17443 tracks the upgrade for the stable branch.

#7 Updated by intrigeri about 2 months ago

  • Status changed from Needs Validation to In Progress

#8 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Needs Validation

#9 Updated by anonym about 2 months ago

  • Assignee set to anonym

#10 Updated by intrigeri about 2 months ago

  • Status changed from Needs Validation to Resolved

This got fixed since #17443 (that has the same commits, cherry-picked) was merged into stable and in turn into devel.

Also available in: Atom PDF