Project

General

Profile

Bug #17380

Graphical distorsions in Thunderbird and Tor Browser on MacBooks with Radeon R9 GPU

Added by goupille 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

A user reported (Bug report: 40655a60062a9dd4081d24396580f01c) that since tails 4.1.1 (they didn't saw the issue on tails 3.x), when starting tor browser or thunderbird, the window displayed is white and the icons and menus only appears when hovered by the mouse and the window content is only displayed in stripes when scrolling.

It was also reported on this reddit post (with tails 4.0) : https://www.reddit.com/r/tails/comments/dnz93w/graphics_bug/

Associated revisions

Revision ab7ccfcc (diff)
Added by intrigeri about 1 month ago

Document known issue and workaround (Closes: #17380)

History

#1 Updated by intrigeri 3 months ago

  • Assignee changed from intrigeri to goupille

A user reported (Bug report: 40655a60062a9dd4081d24396580f01c) that since tails 4.1.1 (they didn't saw the issue on tails 3.x), when starting tor browser or thunderbird, the window displayed is white and the icons and menus only appears when hovered by the mouse and the window content is only displayed in stripes when scrolling.

Ouch!

I see no trace of any application having been started in the Tails session 40655a60062a9dd4081d24396580f01c was reported from: it seems that the user started a fresh Tails and immediately sent a WhisperBack report. To investigate, I'll need debugging info from a session where the bug happened. Thanks in advance!

#2 Updated by goupille 3 months ago

  • Assignee changed from goupille to intrigeri

here is a report with more relevant logs (I hope):

Bug report: c95f42800dfd082bf5fa70251f1cdace

#3 Updated by goupille 3 months ago

apparently the issue began with tails 4.0

#4 Updated by intrigeri 3 months ago

  • Subject changed from graphical distorsions with thunderbird and tor browser on macbooks with Radeon R9 GPU to Graphical distorsions in Thunderbird and Tor Browser on MacBooks with Radeon R9 GPU
  • Category set to Hardware support
  • Status changed from Confirmed to In Progress
  • Type of work changed from Graphics to Research

In the logs I see lots of such errors:

kernel: dmar_fault: 18566 callbacks suppressed                                                                          
kernel: DMAR: DRHD: handling fault status reg 3                                                                         
kernel: DMAR: [DMA Write] Request device [01:00.0] fault addr fe400000 [fault reason 12] non-zero reserved fields in PTE
kernel: DMAR: DRHD: handling fault status reg 3                                                                         
kernel: DMAR: [DMA Write] Request device [01:00.0] fault addr fe40e000 [fault reason 12] non-zero reserved fields in PTE
kernel: DMAR: DRHD: handling fault status reg 3                                                                         
kernel: DMAR: [DMA Write] Request device [01:00.0] fault addr fe412000 [fault reason 12] non-zero reserved fields in PTE
kernel: DMAR: DRHD: handling fault status reg 3                                                                         

Device 01:00.0 is the radeon GPU.

I think that's caused by the INTEL_IOMMU_DEFAULT_ON_INTGPU_OFF option, that's been enabled in the Linux kernel we ship since Tails 4.0.

I'll ask the user to test with intel_iommu=off.

@goupille,

@emmapeel,

and numbat,
I suspect this kernel config change may be the explanation for a number of hardware support regressions that appeared in 4.0. So, please ask users who experience such regressions to try with @intel_iommu=off
, and report back on the corresponding tickets (or to me directly if there's no ticket). Thanks in advance!
If my hunch is confirmed, I think we should at the very least document this workaround prominently, and depending on how widespread the problem is, consider making it the default.

#5 Updated by goupille 3 months ago

apparently adding intel_iommu=off fixes this issue at least for the user that reported it

#6 Updated by goupille 2 months ago

there are more reports from user fixing the issue with 'iommu=off'

#7 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#8 Updated by intrigeri about 1 month ago

  • % Done changed from 100 to 0

Documented the workaround in ab7ccfcc1f0051d1472364e0387271c16da76b4d.
If you have more affected computers to add to the list, please let me know :)

Also available in: Atom PDF