Project

General

Profile

Bug #17319

devel FTBFS: torbrowser profile update needed

Added by CyrilBrulebois 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Filing this as part of the 4.1 release process…

(I might have missed an existing report, I need to grow some redmine-searching skills, or wait for the switch to a gitlab instance… Only found #8910 which seems a tad old).

The devel branch FTBFSes this way:

patching file etc/apparmor.d/torbrowser.Browser.firefox
Hunk #4 FAILED at 48.
Hunk #5 FAILED at 101.
Hunk #6 succeeded at 122 (offset 2 lines).
Hunk #7 succeeded at 157 (offset 2 lines).
2 out of 7 hunks FAILED -- saving rejects to file etc/apparmor.d/torbrowser.Browser.firefox.rej
patching file etc/apparmor.d/tunables/torbrowser
E: config/chroot_local-hooks/19-install-tor-browser-AppArmor-profile failed (exit non-zero). You should check for errors.

This seems to be devel-specific: the stable branch and the 4.1 release built fine.


Related issues

Duplicates Tails - Bug #17265: devel branch FTBFS since torbrowser-launcher 0.3.2-4 was uploaded to sid Resolved

History

#1 Updated by intrigeri 3 months ago

  • Duplicates Bug #17265: devel branch FTBFS since torbrowser-launcher 0.3.2-4 was uploaded to sid added

#2 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to Duplicate

(I might have missed an existing report, I need to grow some redmine-searching skills, or wait for the switch to a gitlab instance… Only found #8910 which seems a tad old).

Hint: the FT view is usually a good starting points for such problems :)

#3 Updated by CyrilBrulebois 3 months ago

Can we standardize on quoting the relevant part of the build log?

#4 Updated by intrigeri 3 months ago

Can we standardize on quoting the relevant part of the build log?

I understand this will make it more likely to find a ticket via full text search.
This makes sense to me, I'll try to remember this!

Also available in: Atom PDF