Project

General

Profile

Bug #17316

Thunderbird is empty (no emails) when started after upgrading to 4.1

Added by sajolida about 1 month ago. Updated 12 days ago.

Status:
New
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

See screenshot in attachment on my machine.

AppArmor is unhappy in the journal:

Dec 04 12:32:49 amnesia kernel: audit: type=1400 audit(1575462769.476:364): apparmor="DENIED" operation="mkdir" profile="thunderbird" name="/home/amnesia/.mozilla/systemextensionsdev/" pid=8581 comm="thunderbird" requested_mask="c" denied_mask="c" fsuid=1000 ouid=1000

Thunderbird output on the command line:

+ . /usr/local/lib/tails-shell-library/tor-browser.sh
+ TBB_INSTALL=/usr/local/lib/tor-browser
+ TBB_PROFILE=/etc/tor-browser/profile
+ TBB_EXT=/usr/local/share/tor-browser-extensions
+ TOR_LAUNCHER_INSTALL=/usr/local/lib/tor-launcher-standalone
+ TOR_LAUNCHER_LOCALES_DIR=/usr/local/lib/tor-launcher-standalone/chrome/locale
+ THUNDERBIRD_CONFIG_DIR=/home/amnesia/.thunderbird
+ PROFILE=/home/amnesia/.thunderbird/profile.default
+ start_thunderbird
+ export GNOME_ACCESSIBILITY=1
+ unset SESSION_MANAGER
+ reconfigure_profile
+ mkdir -p /home/amnesia/.thunderbird/profile.default
+ configure_locale
+ set_mozilla_pref /home/amnesia/.thunderbird/profile.default/prefs.js intl.locale.requested "" user_pref
+ local file name value prefix
+ file=/home/amnesia/.thunderbird/profile.default/prefs.js
+ name=intl.locale.requested
+ value="" 
+ prefix=user_pref
+ [ -e /home/amnesia/.thunderbird/profile.default/prefs.js ]
+ sed -i /^user_pref("intl.locale.requested",/d /home/amnesia/.thunderbird/profile.default/prefs.js
+ echo user_pref("intl.locale.requested", "");
+ disable_autocrypt
+ set_mozilla_pref /home/amnesia/.thunderbird/profile.default/prefs.js mail.server.default.enableAutocrypt false user_pref
+ local file name value prefix
+ file=/home/amnesia/.thunderbird/profile.default/prefs.js
+ name=mail.server.default.enableAutocrypt
+ value=false
+ prefix=user_pref
+ [ -e /home/amnesia/.thunderbird/profile.default/prefs.js ]
+ sed -i /^user_pref("mail.server.default.enableAutocrypt",/d /home/amnesia/.thunderbird/profile.default/prefs.js
+ echo user_pref("mail.server.default.enableAutocrypt", false);
+ configure_default_incoming_protocol
+ local default_protocol
+ thunderbird_config_is_persistent
+ findmnt --noheadings --output SOURCE --target /home/amnesia/.thunderbird
+ [ /dev/mapper/TailsData_unlocked[/thunderbird] = /dev/mapper/TailsData_unlocked[/thunderbird] ]
+ default_protocol=0
+ set_mozilla_pref /home/amnesia/.thunderbird/profile.default/prefs.js extensions.torbirdy.defaultprotocol 0 user_pref
+ local file name value prefix
+ file=/home/amnesia/.thunderbird/profile.default/prefs.js
+ name=extensions.torbirdy.defaultprotocol
+ value=0
+ prefix=user_pref
+ [ -e /home/amnesia/.thunderbird/profile.default/prefs.js ]
+ sed -i /^user_pref("extensions.torbirdy.defaultprotocol",/d /home/amnesia/.thunderbird/profile.default/prefs.js
+ echo user_pref("extensions.torbirdy.defaultprotocol", 0);
+ thunderbird_profile_is_new
+ [ ! -f /home/amnesia/.thunderbird/profile.default/extensions.json ]
+ exec /usr/bin/thunderbird --class Thunderbird -profile /home/amnesia/.thunderbird/profile.default

I'll also forward a WhisperBack report to the Foundations team as soon as I managed to downgrade to Tails 4.0 and get my emails back :)


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

FWIW, I'm pretty sure I've seen this AppArmor denial in cases when Thunderbird 68 worked just fine, so I doubt it's related.
I probably won't have time to look into it this week.

@goupille, did other users report this?

#3 Updated by goupille about 1 month ago

so far we don't have any reports about this issue, I'll get back if someone reach us about that

#4 Updated by sajolida about 1 month ago

  • Subject changed from Thundebird is empty (no emails) when started after upgrading to 4.1 to Thunderbird is empty (no emails) when started after upgrading to 4.1

#5 Updated by segfault about 1 month ago

sajolida wrote:

See screenshot in attachment on my machine.

I don't see any attachment

#6 Updated by segfault about 1 month ago

I'll also forward a WhisperBack report to the Foundations team as soon as I managed to downgrade to Tails 4.0 and get my emails back :)

I also can't find a WhisperBack report from you in my emails

#7 Updated by sajolida about 1 month ago

I forwarded it just now. Sorry!

#8 Updated by intrigeri 12 days ago

  • Target version changed from Tails_4.2 to Tails_4.3

Also available in: Atom PDF