Project

General

Profile

Bug #17297

USB stick not listed in Tails Installer ("TypeError: Argument 1 does not allow None as a value")

Added by sajolida about 2 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

When I try to update my "unsecure" Tails USB stick that I use for WireframeSketcher and testing the Verification Extension, it is not listed in Tails Installer from Tails 4.0.

If I run Tails Installer from the command line, I get the following error:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/tails_installer/gui.py", line 648, in populate_devices
    self.live.detect_supported_drives(callback=add_devices)
  File "/usr/lib/python2.7/dist-packages/tails_installer/creator.py", line 748, in detect_supported_drives
    callback()
  File "/usr/lib/python2.7/dist-packages/tails_installer/gui.py", line 597, in add_devices
    if self.live.running_device() in [info['udi'], info['parent_udi']]:
  File "/usr/lib/python2.7/dist-packages/tails_installer/creator.py", line 557, in running_device
    return underlying_physical_device(liveos_mountpoint)
  File "/usr/lib/python2.7/dist-packages/tails_installer/utils.py", line 107, in underlying_physical_device
    drive = udisksclient.get_drive_for_block(block)
TypeError: Argument 1 does not allow None as a value

I don't get this error in 3.16 and the same USB stick is listed correctly.

Setting as "Elevated" because it's a regression and it might affect people doing manual upgrades to 4.0 when trying to clone the intermediary Tails to their real Tails.

History

#1 Updated by sajolida about 1 month ago

The same happened on my main Tails today when I tried to downgrade it to 4.0 after #17316. Note that I was trying to upgrade it from itself running in RAM after unplugging and plugging it back again.

#2 Updated by intrigeri about 1 month ago

The same happened on my main Tails today when I tried to downgrade it to 4.0 after #17316. Note that I was trying to upgrade it from itself running in RAM after unplugging and plugging it back again.

I think failure is expected in this case, because Tails Installer tries to figure out which device corresponds to the Tails boot device, and in this case it's gone.
We have quite some code that won't work well with toram. It's always been a second-class citizen. I'm not sure what to do about it in general, but as far as this specific ticket is concerned, I propose we focus on the case when one is not using toram.

#3 Updated by intrigeri about 1 month ago

I see the failure is about figuring out which device Tails was booted from.
So to understand what's going on, I think we need to know what kind of Tails system were you running from when you've experienced this problem.

Was it a USB stick installed from a USB image? Anything else?
In particular, semi-informed guess: was it a Tails installed on an internal drive with live-media=removable removed from the kernel command line?

#4 Updated by sajolida about 1 month ago

  • Status changed from New to Rejected
  • Priority changed from Elevated to Normal

Indeed. I get this bug when running from my main Tails (with toram and without live-media=removable) but not when running from my unsecure Tails (default boot options). I didn't think that these options would matter since I'm trying to "use a downloaded ISO image" but yeah I guess I'm on my own here anyway :)

Also available in: Atom PDF