Project

General

Profile

Bug #17284

cant upload files using unsafe browser

Added by Anonymous 4 months ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

What doesn't work as far as I have checked:

- uploading files directly from external media through unsafe browser

- uploading files from any destination outside of safe browser home folder

Untested thoroughly but possibly doesn't work:

- uploading files in general through unsafe browser, which is done by copying files to unsafe browser home folder then trying to upload them to a website, either because:

1- apparmor prevents copying files to unsafe browser home destination

or

2- even if copying was successful, uploading to a website doesn't work because files are invisible when navigating to that destination through unsafe browser

History

#1 Updated by sajolida 4 months ago

  • Status changed from New to Rejected

Hi!

The Unsafe Browser is only meant as a wait to log into captive portals:

https://tails.boum.org/doc/anonymous_internet/unsafe_browser/

You can't upload or download files with it by design.

#2 Updated by Anonymous 4 months ago

@sajolida

Exactly..

The captive portal I am using requires uploading credentials

so what to do now?

#3 Updated by sajolida 4 months ago

  • Status changed from Rejected to New

I didn't know such captive portals existed and we might have to adapt the underlying technology of the Unsafe Browser to make this possible.

What kind of credentials do you need to upload?

Would you mind sharing more information about this captive portal, maybe the name of the company operating it so we get an idea of how frequent this might be.

Also available in: Atom PDF