Project

General

Profile

Feature #17267

Feature #16771: Upgrade to Thunderbird 68

Fix non-en-US dictionaries not available in Thunderbird 68

Added by segfault 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
feature/17219-replace-torbirdy
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Related issues

Related to Tails - Bug #17150: Spellchecking only available for English in Tor Browser 9 Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision abc69098 (diff)
Added by intrigeri 2 months ago

Thunderbird: make all system-wide spellchecker dictionaries available (refs: #17267)

This is how we fixed the same problem in Tor Browser in commit
714b51bfa455ca4fc54dd297cb1c43737076e1cb (#17150).

It'll probably be fixed differently in Debian:
https://bugs.debian.org/944295

History

#1 Updated by intrigeri 2 months ago

  • Affected tool set to Email Client

#2 Updated by intrigeri 2 months ago

#3 Updated by intrigeri 2 months ago

  • Assignee set to intrigeri

On the Debian side this is tracked as https://bugs.debian.org/944295, which will be fixed in the next upload, but that'll probably be too late for Tails 4.1.

I'll try two things:

  • export DICPATH=/usr/share/hunspell, as done in Debian's Vcs-Git
  • pref("spellchecker.dictionary_path", "/usr/share/hunspell");, as we did in Tor Browser to fix the same problem (#17150)

#4 Updated by intrigeri 2 months ago

  • Status changed from Confirmed to In Progress
  • Feature Branch changed from feature/16771-thunderbird-68+force-all-tests to feature/17219-replace-torbirdy

I'm using the branch that's the most up-to-date, as per #16771#note-33.

#5 Updated by intrigeri 2 months ago

  • Related to Bug #17150: Spellchecking only available for English in Tor Browser 9 added

#6 Updated by intrigeri 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault

Built from abc690987d and this works for me: I can select French language for spellchecking and spellchecking works OK.

#7 Updated by segfault about 2 months ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (segfault)

intrigeri wrote:

Built from abc690987d and this works for me: I can select French language for spellchecking and spellchecking works OK.

Confirmed and code LGTM.

Also available in: Atom PDF