Project

General

Profile

Bug #17252

All branches FTBFS since Thunderbird 68 was uploaded to buster-security

Added by intrigeri 19 days ago. Updated 15 days ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17252-import-thunderbird-60
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Since it's not clear whether we'll manage to ship Thunderbird 68 in Tails 4.1, IMO we should do the simplest possible thing that unblocks other dev work, that is: upload Thunderbird 60 to a suite in our custom APT repo. Setting priority = Urgent as this blocks all other dev work except upgrading to v68.


Related issues

Related to Tails - Feature #16771: Upgrade to Thunderbird 68 Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 9490e689 (diff)
Added by intrigeri 18 days ago

Ship Thunderbird 60 for now (refs: #17252)

Revision 022151b3 (diff)
Added by intrigeri 16 days ago

Install a version of Enigmail that's compatible with Thunderbird 60 (refs: #17252)

I've imported enigmail 2:2.0.12+ds1-1~deb10u1 into our
bugfix-17252-import-thunderbird-60 APT overlay suite.

Revision c53f942d (diff)
Added by segfault 16 days ago

Really install a version of Enigmail compatible with Thunderbird 60 (refs: #17252)

Revision 228b8712
Added by segfault 15 days ago

Merge branch 'bugfix/17252-import-thunderbird-60' into stable (Closes #17252)

Revision a7bb0720 (diff)
Added by intrigeri 14 days ago

Install a version of Enigmail that's compatible with Thunderbird 60 (refs: #17252)

I've imported enigmail 2:2.0.12+ds1-1~deb10u1 into our
bugfix-17252-import-thunderbird-60 APT overlay suite.

Revision 0d8c3620 (diff)
Added by segfault 14 days ago

Really install a version of Enigmail compatible with Thunderbird 60 (refs: #17252)

History

#1 Updated by intrigeri 19 days ago

#2 Updated by intrigeri 18 days ago

  • Assignee set to intrigeri

#3 Updated by intrigeri 18 days ago

  • Feature Branch set to bugfix/17252-import-thunderbird-60

#4 Updated by intrigeri 18 days ago

#5 Updated by intrigeri 18 days ago

  • Status changed from Confirmed to In Progress

#6 Updated by intrigeri 18 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault

#7 Updated by intrigeri 16 days ago

  • Status changed from Needs Validation to In Progress
  • Assignee deleted (segfault)

We need to also import an older enigmail:

08:45:00 The following packages have unmet dependencies:
08:45:00  enigmail : Depends: thunderbird (>= 1:68.0) but 1:60.9.0-1~deb10u1 is to be installed or
08:45:00                      icedove (>= 1:68.0) but it is not installable
08:45:00             Breaks: thunderbird (< 1:68.0) but 1:60.9.0-1~deb10u1 is to be installed
08:45:00 E: Unable to correct problems, you have held broken packages.

#8 Updated by intrigeri 16 days ago

  • Assignee set to intrigeri

#9 Updated by intrigeri 15 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault

Thanks for the additional fix! The branch LGTM at c53f942d0689f51395d5d2e82c8b71ec169799ef. In the 2 test suite runs on Jenkins at that commit, there was only 1 failure which is unrelated to Thunderbird, so let's merge into stable → devel?

#10 Updated by segfault 15 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF