Project

General

Profile

Bug #17214

Drop obsolete customization to hide the "Tor" section in preferences

Added by intrigeri about 1 month ago. Updated 23 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17143-17214-12023-remove-obsolete-tor-browser-customization+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

32a2cf0fc9dc3c9e00d93be816ae5013f66b4468 should not be necessary anymore with Tor Browser 9.0.1 and newer: https://trac.torproject.org/projects/tor/ticket/32210.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocked by Tails - Bug #17143: Re-enable Tor Browser's "Quantum bar" Resolved

Associated revisions

Revision 7f02a0a2 (diff)
Added by intrigeri about 1 month ago

Revert "Hide all Tor connection-related settings in about:preferences in all browsers" (refs: #17214)

Tor Browser 9.0.1 and newer hide these settings when TOR_SKIP_LAUNCH=1 is set,
which is the case for our browsers:
https://trac.torproject.org/projects/tor/ticket/32210

This reverts commit 32a2cf0fc9dc3c9e00d93be816ae5013f66b4468.

Revision 102750ce
Added by intrigeri 26 days ago

Merge branch 'bugfix/17143-17214-12023-remove-obsolete-tor-browser-customization+force-all-tests' into stable (Fix-committed: #17143, #17214, #12023)

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

  • Affected tool set to Browser

#3 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri about 1 month ago

  • Assignee set to intrigeri
  • Target version set to Tails_4.1
  • Feature Branch set to bugfix/17143-17214-remove-obsolete-tor-browser-customization+force-all-tests

I'll try to do that at the same time as #17143, so we have to do the QA & paperwork only once.

#5 Updated by intrigeri about 1 month ago

  • Feature Branch changed from bugfix/17143-17214-remove-obsolete-tor-browser-customization+force-all-tests to bugfix/17143-17214-12023-remove-obsolete-tor-browser-customization+force-all-tests

#6 Updated by intrigeri about 1 month ago

On an image built from this branch, the UI that 32a2cf0fc9dc3c9e00d93be816ae5013f66b4468 hid is still hidden in the Tor Browser and Unsafe Browser.

#7 Updated by intrigeri about 1 month ago

  • Blocked by Bug #17143: Re-enable Tor Browser's "Quantum bar" added

#8 Updated by intrigeri 30 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)

#9 Updated by segfault 28 days ago

  • Assignee set to segfault

LGTM. Won't merge because #12023 is still in progress.

#10 Updated by intrigeri 26 days ago

  • Status changed from Needs Validation to 11
  • % Done changed from 0 to 100

#11 Updated by intrigeri 23 days ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF