Project

General

Profile

Bug #17204

Various user-facing messages still refer to Tails Installer as the canonical way to install Tails

Added by intrigeri about 1 month ago. Updated 13 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
tails.git+iuk.git:bugfix/17204-tails-installer-mentions
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:

Description

A quick git grep points to:

  • config/chroot_local-includes/usr/local/bin/tails-additional-software-config
  • config/chroot_local-includes/usr/local/lib/tails-boot-device-can-have-persistence
  • config/chroot_local-includes/usr/local/sbin/tails-additional-software
  • possibly Tails Upgrader

We should update these messages.


Related issues

Related to Tails - Feature #16721: Adapt the UX of Tails Installer to USB images Resolved
Blocks Tails - Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing Confirmed 01/08/2016

Associated revisions

Revision 7536b77a (diff)
Added by intrigeri 25 days ago

Import branch bugfix/17204-tails-installer-mentions of iuk.git (refs: #17204)

Revision 903aa539 (diff)
Added by intrigeri 13 days ago

Enable the bugfix-17204-tails-installer-mentions APT overlay (refs: #17204).

Revision f6751baa
Added by intrigeri 13 days ago

Merge branch 'bugfix/17204-tails-installer-mentions' into stable (Closes: #17204)

Drop config/chroot_local-patches/iuk-17204.diff: included in tails-iuk 4.0.3-1.

History

#1 Updated by intrigeri about 1 month ago

  • Related to Feature #16721: Adapt the UX of Tails Installer to USB images added

#2 Updated by intrigeri about 1 month ago

Next step could be: list all these messages, explain when users may see them, and ask sajolida how we should rephrase them.

#3 Updated by denkxor about 1 month ago

config/chroot_local-includes/usr/local/bin/tails-additional-software-config

Message:'To do so, install Tails on a USB stick using '
'<a href="tails-installer.desktop">Tails Installer</a> '
'and create a persistent storage.'

Should be showed to the user if configuring additional software and it is impossbile to use persistent storage. This could be the case because
a) tails booted from a non-writeable media, e.g. DVD
b) installed on usb without using tails-installer

Since tails-installer is not longer used to create a tails on usb stick and not needed to be able to used persistent on it case b) will not longer occur. I propose to change the message by removing hint to use installer and just tell the user to use a usb stick.

Proposal: 'To do so, install Tails on a USB stick using '
'and create a persistent storage

config/chroot_local-includes/usr/local/lib/tails-boot-device-can-have-persistence
Message: "The boot device was not created using Tails Installer"

this is a perl script used to test if the boot device is supported for persistence.
There are two seperate if-clauses, the first one catches the case of a non-writeable device (e.g. DVD), the second one catches the case of a device not installed using tails-installer. In the later case a error message is printed.
The second if-clause can simply be removed, since tails-installer is not necessary or recommended to install tails.

config/chroot_local-includes/usr/local/sbin/tails-additional-software
Message:

I'm not sure if the message is showed to the user if booting from DVD or it this case is catched somewhere else. But is should work to just remove the part mentioning tails-installer, so the user is told to use a tails from a usb-stick.

Proposal: "Cannot create persistent storage on this media."
"You could install {packages} automatically when "
"starting Tails" "To do so, you need to run Tails from a USB stick "

#4 Updated by sajolida 28 days ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#5 Updated by sajolida 28 days ago

  • Status changed from Confirmed to Needs Validation
  • Target version set to Tails_4.1
  • Feature Branch set to tails.git+iuk.git:bugfix/17204-tails-installer-mentions

Hi @denkxor, thanks for all the smart suggestions!

Summarizing:

1. config/chroot_local-includes/usr/local/lib/tails-boot-device-can-have-persistence

Before:

The boot device was not created using Tails Installer

Even though this error should not happen anymore, people might still install Tails using the ISO image and get into trouble.

After:

The boot device was not created using a USB image or Tails Installer.

2. tails.git:config/chroot_local-includes/usr/local/bin/tails-additional-software-config

Before:

To do so, install Tails on a USB stick using Tails Installer and create a persistent storage.

After:

To do so, install Tails on a USB stick and create a persistent storage.

3. config/chroot_local-includes/usr/local/sbin/tails-additional-software

Before:

To do so, you need to run Tails from a USB stick installed using Tails Installer.

After:

To do so, you need to run Tails from a USB stick.

In both #2 and #3 I'm ignoring the case of people with the ISO image on a USB stick to keep the message simpler for everybody else.

I also spot a string in iuk.git:

4. iuk.git:lib/Tails/IUK/Frontend.pm

Before:

your device was not created using Tails Installer

After:

your device was not created using a USB image or Tails Installer

Same rationale as #1.

I wrote 2 branches:

tails.git:bugfix/17204-tails-installer-mentions
iuk.git:bugfix/17204-tails-installer-mentions

Both untested as far as the code is concerned.

I couldn't spot anything else.

#6 Updated by intrigeri 25 days ago

  • Assignee set to intrigeri

#7 Updated by intrigeri 25 days ago

  • Status changed from Needs Validation to In Progress

#8 Updated by intrigeri 25 days ago

  • Status changed from In Progress to Needs Validation

Thanks! "Code" review passes, adjusted the test suite in iuk.git accordingly, imported the diff from iuk.git as a patch in tails.git so the test suite exercises it. Let's see what Jenkins thinks!

#9 Updated by intrigeri 24 days ago

Hmm, I see weird ASP failures on Jenkins. Running more tests to tell if that's a regression brought by this branch (I seriously doubt it; could be bad timing vs. the Buster 10.2 point release?).

#10 Updated by intrigeri 13 days ago

  • Status changed from Needs Validation to In Progress

#11 Updated by intrigeri 13 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF