Project

General

Profile

Feature #17197

Clarify from which USB stick to run the rsync when doing a backup

Added by goupille about 1 month ago. Updated 20 days ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
feature/17197-clarify-rsync-command
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

The new documentation on https://tails.boum.org/doc/first_steps/persistence/copy/ can be confusing, especially for people used to the former method : then, you launched the command from the newly installed USB stick, now you need to launch the command from the USB stick you want to backup. I think that the phrasing "current tails" could be clearer.

I just read the rsync manual and can't confirm that launching the command from the USB stick with an empty persistent volume would cause no harm. if it does I think there should be a clear warning.


Related issues

Blocks Tails - Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing Confirmed 01/08/2016

History

#1 Updated by gagz 29 days ago

Hey,

The current rsync command is:

rsync -PaSHAX --del /live/persistence/TailsData_unlocked/ /media/amnesia/TailsData/

This command would definitely be problematic if launched from the backup stick. It would basicaly take everything from /live/persistence/TailsData_unlocked (that means the persistent content of the backup stick) and put it into /media/amnesia/TailsData (which would be the mounted "original" Tails), removing from there anything that's not in /live/persistence/TailsData_unlocked.
So I push with goupille to add a clear warning about it!

Furthermore, the command starts with a #, which is absolutely not understandable for people not used to the terminal. I'd say let's remove this # :)

Thanks for the great work, it's really good to have a nice way to backup Tails!

#2 Updated by sajolida 28 days ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#3 Updated by sajolida 28 days ago

  • Tracker changed from Bug to Feature
  • Subject changed from clarify the backup documentation to Clarify from which USB stick to run the rsync when doing a backup
  • Priority changed from Normal to Elevated
  • Target version set to Tails_4.1

This can lead to data loss, so Elevated and #16711.

#4 Updated by sajolida 28 days ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from sajolida to cbrownstein
  • Feature Branch set to feature/17197-clarify-rsync-command

@goupille: I think that this is a change management issue that will only affect people who were used to the previous doc and to doing the backup while running from their backup Tails. Given that the current scheme is more straight-forward (do the backup from the current Tails instead of restarting on the backup Tails), I think that this issue will fade out with time.

So I propose adding a warning as close as possible to the problem: right on top of the rsync command. See 38ab5c1b2e.

Given that the terminology is "current" vs. "backup", I'm afraid that it's not the core of the problem and that changing "current" into anything else wouldn't solve the issue.

I'm open to find something that might be better for those people (as long as it doesn't make things worse for everybody else in the future) but I couldn't find anything. I thought about "regular" or "usual" but I don't think that it would make any significant difference. And I don't want to use a periphrasis or to make the terminology more cumbersome for everybody else.

@gagz: The '#' on the command line is added using CSS and cannot be copied and pasted. Did you actually see people getting confused by this or is it only a hypothesis? Worse case, if they type the '#' it will be treated as a comment and do no harm.

@cbrownstein: Please have a look at my branch. I'm also interested in your opinion on the topic in general :)

#5 Updated by gagz 28 days ago

@gagz: The '#' on the command line is added using CSS and cannot be copied and pasted. Did you actually see people getting confused by this or is it only a hypothesis? Worse case, if they type the '#' it will be treated as a comment and do no harm.
I recalled that some day a friend of mine copied the full line I sent them (for something unrelated to Tails), and they included the sharp. So I just made them read these instructions here, they tried to copy the full line, figured the sharp wouldn't be copied, then opened a terminal, typed a sharp, and pasted the line. :O
And because they don't know how to figure whether a command was successful or not, they would just believe it was successful even though it was actually doing nothing, because of the leading sharp.

But I bet this sharp is added on every single line of code block? That's indeed hard to remove on this single line…

#6 Updated by cbrownstein 27 days ago

  • Assignee changed from cbrownstein to sajolida

@goupille: I think that this is a change management issue that will only affect people who were used to the previous doc and to doing the backup while running from their backup Tails. Given that the current scheme is more straight-forward (do the backup from the current Tails instead of restarting on the backup Tails), I think that this issue will fade out with time.

I agree with this. I think the issue will fade out with time.

So I propose adding a warning as close as possible to the problem: right on top of the rsync command. See 38ab5c1b2e.

Given that the terminology is "current" vs. "backup", I'm afraid that it's not the core of the problem and that changing "current" into anything else wouldn't solve the issue.

I think the use of "current" is appropriate here, as meaning "the Tails presently (actively) being used."[1] Conversely, the backup Tails is "the Tails not presently (not actively) being used."

[1]: See: https://www.dictionary.com/browse/current

I'm open to find something that might be better for those people (as long as it doesn't make things worse for everybody else in the future) but I couldn't find anything. I thought about "regular" or "usual" but I don't think that it would make any significant difference. And I don't want to use a periphrasis or to make the terminology more cumbersome for everybody else.

I think "regular" and "usual" are less appropriate than "current." They work, but I think current more precisely refers to the Tails that the user wants to back up.

@gagz: The '#' on the command line is added using CSS and cannot be copied and pasted. Did you actually see people getting confused by this or is it only a hypothesis? Worse case, if they type the '#' it will be treated as a comment and do no harm.

Maybe we should consider dropping the '#' in order to be consistent with existing documentation that instructs the user to run a command in a terminal.[2]

[2]: See, e.g.: https://tails.boum.org/doc/advanced_topics/persistence/check_file_system/index.en.html
and also https://tails.boum.org/doc/first_steps/additional_software/index.en.html#index6h2

@cbrownstein: Please have a look at my branch. I'm also interested in your opinion on the topic in general :)

I've pushed a branch with a couple of changes:

https://0xacab.org/cbrownstein/tails/commits/feature/17197-clarify-rsync-command

#7 Updated by goupille 27 days ago

Hi !
(redmine doesn't want to quote your messages, I had to do it by hand...)

@goupille: I think that this is a change management issue that will only affect people who were used to the previous doc and to doing the backup while running from their backup Tails. Given that the current scheme is more straight-forward (do the backup from the current Tails instead of restarting on the backup Tails), I think that this issue will fade out with time.

I agree with this. I think the issue will fade out with time.

I agree that it is mostly an issue for the people that used to follow the former documentation.

So I propose adding a warning as close as possible to the problem: right on top of the rsync command. See 38ab5c1b2e.

I'm ok with that !

Given that the terminology is "current" vs. "backup", I'm afraid that it's not the core of the problem and that changing "current" into anything else wouldn't solve the issue.

I think the use of "current" is appropriate here, as meaning "the Tails presently (actively) being used."[1] Conversely, the backup Tails is "the Tails not presently (not actively) being used."

I pointed that particular phrasing because, in a sense, the former documentation wasn't about "how do I backup my data (from my usual Tails device)" it was about "how do I copy my data on a brand new Tails device (that I will use every day from now on)". if you read the new documentation with that last purpose in mind, "current Tails" doesn't seem enough to identify the right one.

#8 Updated by sajolida 21 days ago

So I just made them read these instructions here, they tried to copy the full line, figured the sharp wouldn't be copied, then opened a terminal, typed a sharp, and pasted the line. :O
And because they don't know how to figure whether a command was successful or not, they would just believe it was successful even though it was actually doing nothing, because of the leading sharp.

Wow, that's super useful feedback! I'll get rid of them straight away.

#9 Updated by sajolida 21 days ago

  • Assignee changed from sajolida to cbrownstein

Thanks Cody and goupille for confirming the fix.

https://0xacab.org/cbrownstein/tails/commits/feature/17197-clarify-rsync-command

Oops, sorry for letting a 'it' lying around carelessly like this!

I pushed 2 more commits on my branch, please have a look again.

#10 Updated by cbrownstein 21 days ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from cbrownstein to sajolida

Looks good!

#11 Updated by sajolida 20 days ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Merged.

Also available in: Atom PDF