Project

General

Profile

Bug #17185

Etcher fails to install Tails 4 IMG file (corrupted image?)

Added by goupille about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

multiple users (at least two are using macOS) reported that after downloading the IMG file without errors, Etcher failed to install it on the USB stick with this error message :

Something went wrong. If it is a compressed image, please check that the archive is not corrupted.

the first reports were received 10/2/19 around 4 AM

@sajolida


Related issues

Blocks Tails - Feature #16688: Core work 2019Q3 → 2019Q4: User experience Confirmed

History

#1 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to goupille

I tried to burn Tails 4.0 using Etcher 1.5.51 (the version linked from our website) on macOS High Sierra and it worked fine 2 times in a row.

Maybe it's this error in Etcher: https://github.com/balena-io/etcher/issues/2833.

To confirm this, I need to know from people experiencing this issue:

  • What is their version of macOS.
  • Whether it works to run Etcher from a Terminal with sudo:
sudo /Applications/balenaEtcher.app/Contents/MacOS/balenaEtcher

Once it's confirmed that we are facing Etcher#2833, we could document the workaround.

I'll also track Etcher#2833 and update the version that we distribute as soon as it's fixed upstream.

#2 Updated by sajolida about 1 month ago

  • Description updated (diff)

#3 Updated by goupille about 1 month ago

  • Assignee changed from goupille to sajolida

a user confirmed that starting etcher from a terminal with sudo fixed the issue

#4 Updated by sajolida about 1 month ago

  • Status changed from In Progress to Confirmed
  • Target version set to Tails_4.1
  • Type of work changed from Research to End-user documentation

Ok, then let's assume that we're facing only https://github.com/balena-io/etcher/issues/2833 and document the workaround on our installation pages.

#5 Updated by sajolida about 1 month ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#6 Updated by sajolida about 1 month ago

  • Blocks deleted (Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing)

#7 Updated by sajolida about 1 month ago

  • Blocks Feature #16688: Core work 2019Q3 → 2019Q4: User experience added

#8 Updated by sajolida about 1 month ago

Actually, Etcher says they fixed it now: https://github.com/balena-io/etcher/issues/2833#event-2773685638. So instead I should update to Etcher 1.5.61 on our website. That's UX work.

#9 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

I updated Etcher to 1.5.61, which should fix the problem.

#10 Updated by numbat about 1 month ago

Confirmed by a user running MacOS Catalina (10.15), this worked for them:

sudo /Applications/balenaEtcher.app/Contents/MacOS/balenaEtcher

Also available in: Atom PDF