Project

General

Profile

Bug #17177

Greeter has no option to 'Show Passphrase' anymore

Added by MixiMilas 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
bugfix/17177-greeter-show-passphrase-button
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

In tails 4.0, contrary to older version, the greeter has no option to 'show passphrase' while typing when you try to unlock the persistence.


Related issues

Related to Tails - Bug #17240: "AttributeError: Handler cb_checkbutton_storage_show_passphrase_toggled not found" on Greeter close Resolved
Duplicated by Tails - Feature #17211: Greeter: Bring back Show Password feature Duplicate
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision fee66f84 (diff)
Added by segfault 5 months ago

Bring back the "Show Passphrase" button in the Greeter (refs: #17177)

Revision d99e22bc (diff)
Added by segfault 5 months ago

Bring back the "Show Passphrase" button in the Greeter (refs: #17177)

History

#1 Updated by intrigeri 5 months ago

  • Status changed from New to Confirmed
  • Assignee set to segfault
  • Affected tool set to Greeter

Hi @segfault,

I've reproduced this regression. Do you want to take care of it?

#2 Updated by intrigeri 5 months ago

#3 Updated by intrigeri 5 months ago

  • Target version set to Tails_4.1

#4 Updated by segfault 5 months ago

  • Status changed from Confirmed to Needs Validation
  • Assignee deleted (segfault)
  • Feature Branch set to bugfix/17177-greeter-show-passphrase-button

#5 Updated by segfault 5 months ago

  • Status changed from Needs Validation to In Progress

#6 Updated by segfault 5 months ago

  • Status changed from In Progress to Needs Validation

#7 Updated by intrigeri 5 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee set to segfault

Hi segfault,

woohoo, that was fast!

Could you please transplant your branch onto stable, so we can ship this fix in 4.1? (Besides, devel-based branches FTBFS at the moment so our CI can't test this branch.)

For details, see https://lists.autistici.org/message/20191019.124146.e0d2338f.en.html :)

#8 Updated by segfault 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

intrigeri wrote:

Could you please transplant your branch onto stable, so we can ship this fix in 4.1?

Done. Sorry I keep forgetting that.

#9 Updated by intrigeri 5 months ago

Thanks! :)

#10 Updated by segfault 5 months ago

  • Duplicated by Feature #17211: Greeter: Bring back Show Password feature added

#11 Updated by sajolida 5 months ago

  • Subject changed from Greeter has no option to 'unhide' passphrase to Greeter has no option to 'Show Passphrase' anymore

#12 Updated by intrigeri 5 months ago

  • Assignee set to intrigeri

#13 Updated by intrigeri 5 months ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (intrigeri)

LGTM, merged!

In passing: https://redmine.tails.boum.org/code/projects/tails/issues?query_id=194 has a few branches that are waiting for review, some of them since 2+ weeks. Hint, hint :)

#14 Updated by intrigeri 5 months ago

  • Related to Bug #17236: Enable the init_on_alloc=1 and init_on_free=1 Linux options added

#15 Updated by intrigeri 5 months ago

  • Related to deleted (Bug #17236: Enable the init_on_alloc=1 and init_on_free=1 Linux options)

#16 Updated by intrigeri 5 months ago

  • Related to Bug #17240: "AttributeError: Handler cb_checkbutton_storage_show_passphrase_toggled not found" on Greeter close added

Also available in: Atom PDF