Project

General

Profile

Bug #17166

Unknown escape sequence in tails-gdm-failed-to-start.service

Added by segfault 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17166-fix-unknown-escape-sequence
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The journal of a booted 4.0~rc1 image contains this message:

/lib/systemd/system/tails-gdm-failed-to-start.service:11: Ignoring
unknown escape sequences: "MAX_LENGTH=254 ;       PREFIX="Error starting
GDM with your graphics card: " ;       SUFFIX=". Please take note of
this error and visit https://tails.boum.org/gdm for troubleshooting." ;
      MAX_VIDEO_CARD_LENGTH=$(($MAX_LENGTH - $(echo -n "$PREFIX$SUFFIX" 
| wc -c))) ;       VIDEO_CARD=$(lspci -d::0300 -nn | sed -E "s,.* VGA
compatible controller \[0300\]: *,," | cut -c
"1-$MAX_VIDEO_CARD_LENGTH") ;       /bin/plymouth display-message
--text="$PREFIX$VIDEO_CARD$SUFFIX"      " 

Associated revisions

Revision f27236ef (diff)
Added by segfault 3 months ago

Fix escape sequence in tails-gdm-failed-to-start.service (refs: #17166)

The command works, but produces this message:

/lib/systemd/system/tails-gdm-failed-to-start.service:11: Ignoring
unknown escape sequences: "MAX_LENGTH=254 ; PREFIX="Error starting
GDM with your graphics card: " ; SUFFIX=". Please take note of
this error and visit https://tails.boum.org/gdm for troubleshooting." ;
MAX_VIDEO_CARD_LENGTH=$(($MAX_LENGTH - $(echo -n "$PREFIX$SUFFIX" | wc -c))) ; VIDEO_CARD=$(lspci -d::0300 -nn | sed -E "s,.* VGA
compatible controller \[0300\]: *,," | cut -c
"1-$MAX_VIDEO_CARD_LENGTH") ; /bin/plymouth display-message
--text="$PREFIX$VIDEO_CARD$SUFFIX" "

Adding a backslash fixes that and the command still works.

Revision 3d1a4029
Added by intrigeri about 1 month ago

Merge branch 'bugfix/17166-fix-unknown-escape-sequence' into stable (Closes: #17166)

History

#1 Updated by segfault 3 months ago

  • Target version set to Tails_4.0

#2 Updated by intrigeri 3 months ago

FTR and FWIW: this has been the case since I implemented this feature. I did not manage to fix it back then, but (at least back then) it did not prevent this feature from working. I don't recall testing it on Buster though, so possibly with a newer systemd things are different.

#3 Updated by intrigeri 3 months ago

  • Target version changed from Tails_4.0 to Tails_4.1

#4 Updated by segfault about 2 months ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from segfault to intrigeri
  • Target version changed from Tails_4.1 to Tails_4.2
  • Feature Branch set to bugfix/17166-fix-unknown-escape-sequence

Forgot that I already had a branch on which this is fixed.

#5 Updated by segfault about 2 months ago

  • Status changed from Needs Validation to In Progress

#6 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Needs Validation

I'm assuming the previous status change was a mistake.

#7 Updated by segfault about 1 month ago

intrigeri wrote:

I'm assuming the previous status change was a mistake.

Correct.

#8 Updated by intrigeri about 1 month ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

#9 Updated by CyrilBrulebois about 1 month ago

  • Target version changed from Tails_4.2 to Tails_4.1.1

Adjusting target version, it's getting released in 4.1.1 instead of the planned 4.2 (only bugfix in addition to #17320).

Also available in: Atom PDF