Project

General

Profile

Feature #17151

Point Tails Upgrader to /doc/upgrade

Added by sajolida about 1 month ago. Updated 15 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
iuk.git:feature/17151-rename-doc-url
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Upgrader

Description

It was renamed in d3ced622fa to make our documentation index easier to read.

The redirection in #17146 will take care of older Tails versions so it's not super urgent.


Related issues

Related to Tails - Feature #17146: Redirect /doc/first_steps/upgrade/ to /doc/upgrade Resolved
Related to Tails - Feature #10885: Better integrate new upgrade scenarios with upgrade documentation Resolved 01/08/2016
Related to Tails - Feature #16991: Cognitive walkthrough of automatic and manual upgrades Confirmed

History

#1 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to Needs Validation
  • Assignee deleted (sajolida)
  • Feature Branch set to iuk.git:feature/17151-rename-doc-url

#2 Updated by sajolida about 1 month ago

  • Related to Feature #17146: Redirect /doc/first_steps/upgrade/ to /doc/upgrade added

#3 Updated by sajolida about 1 month ago

  • Related to Feature #10885: Better integrate new upgrade scenarios with upgrade documentation added

#4 Updated by intrigeri about 1 month ago

  • Assignee set to intrigeri
  • Target version set to Tails_4.0

#5 Updated by intrigeri about 1 month ago

  • Target version deleted (Tails_4.0)

Given it's not super urgent, it might wait until 4.1.

#6 Updated by sajolida 29 days ago

  • Related to Feature #16991: Cognitive walkthrough of automatic and manual upgrades added

#7 Updated by intrigeri 24 days ago

  • Target version set to Tails_4.1

#8 Updated by intrigeri 23 days ago

  • Status changed from Needs Validation to In Progress

@sajolida, I'm wondering about the #manual part, for the same reason I explained on the tails-dev list a couple days ago. I think it's exactly the same question that we're trying to answer there:

  • Either we want users who need to do a manual upgrade to land on top of /upgrade so they get a chance to read the common intro, and then we should not append #manual to the link here either.
  • Or we want to avoid one extra navigation hop and instead point to #manual (as done on this branch), but then we should do this in the release notes too.

Makes sense?

#9 Updated by intrigeri 23 days ago

  • Assignee changed from intrigeri to sajolida

#10 Updated by sajolida 22 days ago

Answered on tails-dev. Plus, I think it's fine for manual upgraders to
miss the intro because it contains only information that they will get
anyway when starting from #manual.

#11 Updated by intrigeri 16 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from sajolida to intrigeri

Deal!

#12 Updated by intrigeri 15 days ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (intrigeri)

Released in tails-iuk 4.0.2-1, that'll be part of Tails 4.1.

Note that in this context, unfuzzying PO files is a waste of your time: Transifex only pulls the POT file so these translations will be fuzzy anyway next time we import them, unless translators do the same work that you did.

Also available in: Atom PDF