Project

General

Profile

Bug #17150

Feature #16356: Upgrade to Tor Browser 9.0 (based on Firefox 68)

Spellchecking only available for English in Tor Browser 9

Added by intrigeri about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Internationalization
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17150-fix-tor-browser-spellchecking
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

Nothing in Tor's Trac about this.

Note that the Thunderbird maintainer in Debian wrote:

One more important change is the impossibility to use system wide
installed dictionaries. At least I haven't found a way to still use
them. If this can't get changed all the recommends on the dictionary
packages will get useless. If someone can contribute something here to
solve this I'm happy to take this help!


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision eeeb73b7 (diff)
Added by intrigeri about 1 month ago

Document known issue (refs: #17150)

Revision f63c1a11
Added by intrigeri about 1 month ago

Merge branch 'bugfix/17150-fix-tor-browser-spellchecking' into testing (Closes: #17150)

History

#1 Updated by intrigeri about 1 month ago

System-wide hunspell dictionaries work in Firefox 68 on my sid system. The firefox (61.0-2) changelog entry reads:

  * debian/browser.links.in, debian/rules, debian/vendor.js: Use the
    spellchecker.dictionary_path pref to set the hunspell directory.

Doing so via about:config in a running Tails 4.0~rc1 fixes the problem.

#2 Updated by intrigeri about 1 month ago

#3 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress

#4 Updated by segfault about 1 month ago

  • Assignee set to segfault

#5 Updated by segfault about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Feature Branch set to bugfix/17150-fix-tor-browser-spellchecking

#6 Updated by intrigeri about 1 month ago

  • Assignee set to intrigeri

#7 Updated by intrigeri about 1 month ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from intrigeri to segfault

Dear @segfault, I believe you've not pushed your branch yet :)

#8 Updated by segfault about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from segfault to intrigeri

intrigeri wrote:

Dear @segfault, I believe you've not pushed your branch yet :)

Indeed. Did that now.

#9 Updated by intrigeri about 1 month ago

Thank you. I've transplanted the branch onto testing, so this fix can get into 4.0. I'll come back to it once our CI has tested this updated branch.

#10 Updated by intrigeri about 1 month ago

Built, tested manually: works flawlessly as expected. If we had a "merge once CI has passed" button, I would click it right away! Oh well, there's no such button yet.

#11 Updated by intrigeri about 1 month ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

#12 Updated by intrigeri about 1 month ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF