Project

General

Profile

Bug #17132

Don't ship 16-greeter hook dependency

Added by segfault 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17132-dont-ship-greeter-hook-dependency
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Today I learned that we have a function that we can use in the hooks to install dependencies and remove them afterwards, so that we don't ship them in our releases. I remembered that I installed a hook dependency for 16-greeter recently - I think we should use ensure_hook_dependency_is_installed() instead.

The relevant commit it 77ebe7c70c80fc84bbc172369537a1ada04ca8d1.


Related issues

Related to Tails - Bug #17139: Only ship locale definitions that the user can select in the Greeter Confirmed
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision fb3b3efd (diff)
Added by segfault 5 months ago

Don't ship locales package (refs: #17132)

The locales package is only required by the 16-greeter hook, so we use
ensure_hook_dependency_is_installed() to install/remove it there.

Revision 894d783d
Added by intrigeri 5 months ago

Merge remote-tracking branch 'origin/bugfix/17132-dont-ship-greeter-hook-dependency' into devel (Closes: #17132)

Revision 1dc510eb (diff)
Added by segfault 5 months ago

Actually remove the locales package (refs: #17132)

Fixup against fb3b3efd1229d7f01df6b1f8e4d30a8c986c9087.

It's unclear why the apt-get autoremove command doesn't already
delete the locales package. But removing it explicitly in the
98-remove_unwanted_packages hook works.

Revision 82e180bc
Added by intrigeri 4 months ago

Merge remote-tracking branch 'origin/bugfix/17132-dont-ship-greeter-hook-dependency' into testing (Closes: #17132)

History

#1 Updated by segfault 5 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by segfault 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

#3 Updated by segfault 5 months ago

#4 Updated by intrigeri 5 months ago

  • Feature Branch set to bugfix/17132-dont-ship-greeter-hook-dependency

#5 Updated by intrigeri 5 months ago

  • Assignee set to intrigeri

#6 Updated by intrigeri 5 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

#7 Updated by intrigeri 5 months ago

  • Related to Bug #17139: Only ship locale definitions that the user can select in the Greeter added

#8 Updated by intrigeri 5 months ago

  • Status changed from Resolved to In Progress
  • Assignee deleted (intrigeri)
  • % Done changed from 100 to 50

Hmm, I'm confused. I think I did check that on this branch, the locales package did not end up in the resulting images. But maybe I've been sloppy and forgot that step. Either way, the locales package is included in 4.0~rc1. I'm not sure why apt-get --yes --purge autoremove does not remove it: it could be because locales is Priority: standard, or because APT does not notice that the dependencies of other packages are already satisfied by locales-all — go figure.

Anyway, this package is rather large, so let's try to remove it again. I think we'll need to explicitly deinstall it in config/chroot_local-hooks/98-remove_unwanted_packages.

#9 Updated by segfault 5 months ago

  • Assignee set to segfault

#10 Updated by segfault 4 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

#11 Updated by segfault 4 months ago

  • Status changed from Needs Validation to In Progress

#12 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Needs Validation

(I assume reverting to "In Progress" was caused by pushing an extra commit that references this ticket, possibly due to rebasing.)

#13 Updated by intrigeri 4 months ago

  • Assignee set to intrigeri

#14 Updated by intrigeri 4 months ago

Code review passes. I'll check that the Greeter still works before merging.

#15 Updated by intrigeri 4 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF