Project

General

Profile

Bug #17127

Downgrade po4a to Stretch's 0.47-2

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17127-po4a-from-stretch
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It seems we won't manage to do #17005 by upgrading All The Things to po4a 0.55 in time for Tails 4.0, so for now let's do it by ensuring all relevant systems run 0.47-2.


Related issues

Related to Tails - Bug #17005: Upgrade to po4a 0.55 in Tails itself, in the Vagrant build box, on {translate,www}.lizard, and on RM's systems Confirmed
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision ca4e0558 (diff)
Added by intrigeri 5 months ago

Enable the bugfix-17127-po4a-from-stretch APT overlay (refs: #17127).

Revision 879e66ee (diff)
Added by intrigeri 5 months ago

Install Stretch's po4a (0.47-2) from our custom APT repository (refs: #17127)

Revision a8159b6f
Added by segfault 5 months ago

Merge branch 'bugfix/17127-po4a-from-stretch' into devel (Closes: #17127)

History

#1 Updated by intrigeri 5 months ago

  • Related to Bug #17005: Upgrade to po4a 0.55 in Tails itself, in the Vagrant build box, on {translate,www}.lizard, and on RM's systems added

#2 Updated by intrigeri 5 months ago

#3 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri 5 months ago

  • Feature Branch set to bugfix/17127-po4a-from-stretch

#5 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)

Please review & merge into devel.

Note that we do not install po4a by default, so all that matters here is APT pinning that Additional Software will use.

I applied the changes made on this branch to a running Tails devel, then confirmed that apt update && apt install po4a installs the intended version.

I did not bother:

  • testing po4a in an image built from this branch, because I've been using that version of po4a on sid for months (as per the RM doc)
  • looking at CI results apart of image build, because I don't see how adding an APT source + pinning for a package we don't install could affect Tails' behavior

#6 Updated by segfault 5 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF