Project

General

Profile

Bug #17116

Improve lost persistence.conf instructions on known issues page

Added by cbrownstein 6 months ago. Updated 15 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

  • instead of reconfiguring the persistent features, persistence.conf.bak can be copied to persistence.conf
  • ownership of /live/persistence/TailsData_unlocked might need to be reset to root:root
  • warning: live-additional-software.conf might end up lost without a backup

Related issues

Related to Tails - Bug #10976: persistence.conf lost, recoverable by reconfiguring In Progress 02/12/2019
Related to Tails - Bug #17112: Persistence config files "insecure" backup get emptied in some situations Resolved
Blocks Tails - Feature #17247: Core work 2020Q1 → 2020Q2: Technical writing Confirmed

History

#1 Updated by cbrownstein 6 months ago

  • Related to Bug #10976: persistence.conf lost, recoverable by reconfiguring added

#2 Updated by cbrownstein 6 months ago

  • Related to Bug #17112: Persistence config files "insecure" backup get emptied in some situations added

#3 Updated by cbrownstein 5 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by cbrownstein 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from cbrownstein to sajolida

Here's a branch:

https://0xacab.org/cbrownstein/tails/commits/doc/17116-improve-known-issue-persistence-conf

  • instead of reconfiguring the persistent features, persistence.conf.bak can be copied to persistence.conf

I decided not to document this. The already-documented way is simpler.

  • ownership of /live/persistence/TailsData_unlocked might need to be reset to root:root

Done.

  • warning: live-additional-software.conf might end up lost without a backup

I'll probably create a separate ticket for this.

#5 Updated by sajolida 3 months ago

  • Blocks Feature #17247: Core work 2020Q1 → 2020Q2: Technical writing added

#6 Updated by sajolida 3 months ago

  • Target version set to Tails_4.3

Oops, sorry @cbrownstein for not seeing this one earlier! I probably missed it because it was not part of our view. I added it back to our view (#17247) and my radar now.

#7 Updated by anonym about 2 months ago

  • Target version changed from Tails_4.3 to Tails_4.4

#8 Updated by CyrilBrulebois 27 days ago

  • Target version changed from Tails_4.4 to Tails_4.5

#9 Updated by sajolida 15 days ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (sajolida)

All good! Merged now. Sorry I lost it from sight a second time :(((

Also available in: Atom PDF