Project

General

Profile

Bug #17106

Bug #16774: Transifex translations: we should not update from the _completed branches

Don't import PO files with no translated string from Transifex

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Internationalization
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
bugfix/17106-dont-import-empty-po-files
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

On #16774 we decided we want to import from Transifex:

  • only reviewed translations → this was done for the tails-misc resource on the tails-misc_release branch
  • only PO files with at least one translated+reviewed string → emmapeel tells me she can't do this on Tor's side, so we need to filter out these PO files in import-translations

This matters because the code on #16095 will make decisions based on which PO files are present in tails.git:po/, and it assumes that the aforementioned criteria is implemented there.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocks Tails - Feature #16095: Curate the list of languages in Tails Greeter Resolved 11/04/2018

Associated revisions

Revision 0710b712 (diff)
Added by intrigeri 5 months ago

Refactor: move functions to our shell library (refs: #17106).

I'll need count_msgids() in import-translations.

Revision f7f192f4 (diff)
Added by intrigeri 5 months ago

Refactor: move code to a function (refs: #17106)

I'll need this in import-translations too.

Revision f53b20f7 (diff)
Added by intrigeri 5 months ago

import-translations: don't import PO files with no translated string (refs: #17106)

On #16774 we decided we want to import from Transifex:

- only reviewed translations → this was done for the tails-misc resource on the
tails-misc_release branch
- only PO files with at least one translated+reviewed string → emmapeel tells
me she can't easily do this on Tor's side, so we need to filter out these PO
files in import-translations

This matters because the code on #16095 will make decisions based on which PO
files are present in tails.git:po/, and it assumes that the aforementioned
criteria is implemented there.

Revision df30aca5 (diff)
Added by intrigeri 5 months ago

Refactor: move functions to our shell library (refs: #17106).

I'll need count_msgids() in import-translations.

Revision b19bd7b6 (diff)
Added by intrigeri 5 months ago

Refactor: move code to a function (refs: #17106)

I'll need this in import-translations too.

Revision 9838cfd8 (diff)
Added by intrigeri 5 months ago

import-translations: don't import PO files with no translated string (refs: #17106)

On #16774 we decided we want to import from Transifex:

- only reviewed translations → this was done for the tails-misc resource on the
tails-misc_release branch
- only PO files with at least one translated+reviewed string → emmapeel tells
me she can't easily do this on Tor's side, so we need to filter out these PO
files in import-translations

This matters because the code on #16095 will make decisions based on which PO
files are present in tails.git:po/, and it assumes that the aforementioned
criteria is implemented there.

History

#1 Updated by intrigeri 5 months ago

#2 Updated by intrigeri 5 months ago

  • Blocks Feature #16095: Curate the list of languages in Tails Greeter added

#3 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to segfault
  • Priority changed from Normal to Elevated
  • Feature Branch set to bugfix/17106-dont-import-empty-po-files

Hi @segfault, this review is a little bit more urgent than the other ones I have queued a week ago or so: it blocks #16095 and I'd rather not have to do this by hand when I prepare 4.0~rc1 :)

#5 Updated by intrigeri 5 months ago

  • Status changed from Needs Validation to In Progress

#6 Updated by segfault 5 months ago

  • Status changed from In Progress to 11

Oh, rebasing on origin/devel dropped my merge commit.

#7 Updated by segfault 5 months ago

  • Status changed from 11 to Resolved
  • Assignee deleted (segfault)

Also available in: Atom PDF