Project

General

Profile

Bug #17100

devel branch FTBFS: linux-image-5.2.0-2-amd64 not available

Added by segfault 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17100-upgrade-linux-to-5.2.0-3
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Bug #17104: "Erasure of memory freed by killed userspace processes" test scenario regression caused by the ugprade to Linux 5.2.0-3 Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision f9c7b176 (diff)
Added by segfault 5 months ago

Upgrade the Linux kernel to 5.2.0-3, current version = 5.2.17-1 (refs: #17100)

Revision 1736705c (diff)
Added by segfault 5 months ago

Upgrade the Linux kernel to 5.2.0-3, current version = 5.2.17-1 (refs: #17100)

Revision 61d4030e (diff)
Added by segfault 5 months ago

Upgrade the Linux kernel to 5.2.0-3, current version = 5.2.17-1 (refs: #17100)

Revision 9d6d72ff (diff)
Added by segfault 5 months ago

Upgrade the Linux kernel to 5.2.0-3, current version = 5.2.17-1 (refs: #17100)

Revision 28d07dce
Added by intrigeri 5 months ago

Merge remote-tracking branch 'origin/bugfix/17100-upgrade-linux-to-5.2.0-3' into devel

Closes: #17100

History

#1 Updated by segfault 5 months ago

  • Blocks Bug #17007: JavaScript sometimes blocked on Tor Browser first start ⇒ "Watching a WebM video over HTTPS" and "Playing an Ogg audio track" scenarios are fragile: blocked by NoScript click-to-play added

#2 Updated by segfault 5 months ago

  • Blocks deleted (Bug #17007: JavaScript sometimes blocked on Tor Browser first start ⇒ "Watching a WebM video over HTTPS" and "Playing an Ogg audio track" scenarios are fragile: blocked by NoScript click-to-play)

#3 Updated by segfault 5 months ago

#4 Updated by segfault 5 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by intrigeri 5 months ago

  • Priority changed from Normal to High
  • Feature Branch set to bugfix/17100-upgrade-linux-to-5.2.0-3

#6 Updated by intrigeri 5 months ago

Thanks! I'll run the full test suite locally (the branch hasn't +force-all-tests so Jenkins won't do that for us) and will merge if happy, as this blocks most other current FT work.

#7 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Needs Validation

(So that our CI tests build reproducibility.)

#8 Updated by segfault 5 months ago

intrigeri wrote:

Thanks! I'll run the full test suite locally (the branch hasn't +force-all-tests so Jenkins won't do that for us) and will merge if happy, as this blocks most other current FT work.

Oh right, I forgot to add +force-all-tests.

Status changed from In Progress to Needs Validation

(So that our CI tests build reproducibility.)

Should I have done that before I got the Jenkins test results? If so, in which cases should I do that? Because I got used to waiting for the test results before setting the status to "Needs Validation" (as documented in contribute/merge_policy).

#9 Updated by intrigeri 5 months ago

Because I got used to waiting for the test results before setting the status to "Needs Validation" (as documented in contribute/merge_policy).

That's fine! I just wanted to save some time and be able to merge faster, if/once I see the test suite pass.

#10 Updated by intrigeri 5 months ago

I'll run the full test suite locally

"Scenario: Erasure of memory freed by killed userspace processes" failed twice in 2 runs locally. I see it failed on Jenkins too: https://jenkins.tails.boum.org/job/test_Tails_ISO_bugfix-17100-upgrade-linux-to-5.2.0-3/2/cucumber-html-reports/report-feature_3_2622904403.html. I've never seen this happen before so it looks very much like a regression.

Other than that, my 1st test suite run looks OK.

I don't think this regression a blocker for merging this branch so I'll go ahead once my 2nd test suite run finishes.

But we should file a dedicated ticket to investigate whether it's a regression in Linux or an intended change of behaviour that our test suite needs to be adjusted for. In passing, /usr/share/doc/linux-image-5.2.0-3-amd64/changelog.gz has quite a few potentially relevant changes in the mm area.

#11 Updated by intrigeri 5 months ago

  • Related to Bug #17104: "Erasure of memory freed by killed userspace processes" test scenario regression caused by the ugprade to Linux 5.2.0-3 added

#12 Updated by intrigeri 5 months ago

intrigeri wrote:

But we should file a dedicated ticket to investigate whether it's a regression in Linux or an intended change of behaviour that our test suite needs to be adjusted for. In passing, /usr/share/doc/linux-image-5.2.0-3-amd64/changelog.gz has quite a few potentially relevant changes in the mm area.

See you on #17104.

I'm now going to merge this branch so that devel-based work can resume :)

#13 Updated by intrigeri 5 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF