Project

General

Profile

Bug #17063

Feature #15085: Document our translation platform infrastructure

Cleanup translate-server.git

Added by hefee about 1 month ago. Updated 1 day ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:
Translation Platform

Description

As discussed translate-server.git should removed in future, to have everything in public. The information in translate-server.git will end up in blueprints.


Related issues

Related to Tails - Bug #16995: translate.lizard: cron.sh fail with 'Lock wait timeout exceeded; try restarting transaction' Resolved
Related to Tails - Feature #15086: Translation platform: Write design documentation Resolved

Associated revisions

Revision cf4cbc46 (diff)
Added by intrigeri 1 day ago

Import remaining translation platform ops doc from translate-server.git (Closes: #17063)

History

#1 Updated by hefee about 1 month ago

  • Related to Bug #16995: translate.lizard: cron.sh fail with 'Lock wait timeout exceeded; try restarting transaction' added

#2 Updated by intrigeri about 1 month ago

Hi! Thanks for caring. So far I thought that this was covered by the description of #15086 already:

Check the doc that's in the translate-server repo, make sure it's up-to-date and correct, and ideally move whatever can be published to tails.git.

But I see how having a dedicated ticket can help make this task more visible.

What about making this ticket a subtask of #15086 or #15085?

#3 Updated by hefee about 1 month ago

  • Parent task set to #15085

intrigeri wrote:

Hi! Thanks for caring. So far I thought that this was covered by the description of #15086 already:

Check the doc that's in the translate-server repo, make sure it's up-to-date and correct, and ideally move whatever can be published to tails.git.

Well having a design doc does not mean, that the git repo should die.

But I see how having a dedicated ticket can help make this task more visible.

What about making this ticket a subtask of #15086 or #15085?

#15085 as parent task makes sense. #15086 doesn't make sense, as we don't need to delete the git repo in order to finish #15086.

#4 Updated by hefee 18 days ago

  • Related to Feature #15086: Translation platform: Write design documentation added

#5 Updated by hefee 18 days ago

  • Assignee changed from hefee to intrigeri

As @u and me scanned through the repository, we moved everything into public space. But we are unsure where to move the `sysadmin.mwdn`. Should we move the content also in the blueprint under "Weblate adminstriation"? Or have you any better ideas?

#6 Updated by intrigeri 18 days ago

  • Assignee changed from intrigeri to hefee

Hi!

As u and me scanned through the repository, we moved everything into public space.

Congrats!

But we are unsure where to move the `sysadmin.mwdn`. Should we move the content also in the blueprint under "Weblate adminstriation"? Or have you any better ideas?

First, note that the blueprint is a temporary work space. Think of it as a whiteboard. It's not a good place to store documentation/information that will be useful, and shall be maintained, on the long term. Both design doc and operations doc should live under /contribute/ on our website.

For the case at hand, IMO:

  • The design doc should live under /contribute/design/.
  • Howto-style operations doc, such as what we have in sysadmin.mdwn at the moment, should live in a sub-page of the translation platform maintainers role definition (which we'll have once we've done #17050), that is probably something like /contribute/working_together/roles/translation_platform_maintainer/operations/.

#7 Updated by intrigeri 18 days ago

Thinking about this a bit more, I think we have some amount of flexibility wrt. the future of translate-server.git:

  • On the one hand, there's stuff that should definitely be public, because we want to share and allow others to help us.
  • On the other hand, there's secret stuff that can't be published.
  • In between, there's a grey area. Many Tails teams have their own operations procedures documented in a private Git repo. It's not that it's particularly secret, it's more a matter of convenience, or simply not having invested the time+energy to move info to a public place, because the cost/benefit is too big. That's OK.

So at this point, I'm personally totally fine with having some info left in translate-server.git, and not spend time on moving it to tails.git, for example if that information is unlikely to be useful to anyone but the folks who operate our Weblate instance.

#8 Updated by hefee 16 days ago

intrigeri wrote:

Hi!

As u and me scanned through the repository, we moved everything into public space.

Congrats!

But we are unsure where to move the `sysadmin.mwdn`. Should we move the content also in the blueprint under "Weblate adminstriation"? Or have you any better ideas?

First, note that the blueprint is a temporary work space. Think of it as a whiteboard. It's not a good place to store documentation/information that will be useful, and shall be maintained, on the long term. Both design doc and operations doc should live under /contribute/ on our website.

For the case at hand, IMO:

  • The design doc should live under /contribute/design/.
  • Howto-style operations doc, such as what we have in sysadmin.mdwn at the moment, should live in a sub-page of the translation platform maintainers role definition (which we'll have once we've done #17050), that is probably something like /contribute/working_together/roles/translation_platform_maintainer/operations/.

In the end we only talk about sysadmin.mdwn atm. as everything else is now in the blueprint. I think it makes sense to have a subpage with sysadmin,mdwn stuff.

u, @intrigeri I would suggest let's review @sysadmin.mwdn in the repo and than after #17050, we deside where we move this stuff?

#9 Updated by hefee 16 days ago

  • Blocked by Bug #17050: Translation platform: design & implement long-term maintenance & support plan added

#10 Updated by hefee 16 days ago

  • Subject changed from Remove translate-server.git to Cleanup translate-server.git

#11 Updated by intrigeri 16 days ago

In the end we only talk about sysadmin.mdwn atm. as everything else is now in the blueprint. I think it makes sense to have a subpage with sysadmin,mdwn stuff.

OK.

u, intrigeri I would suggest let's review sysadmin.mwdn in the repo and than after #17050, we deside where we move this stuff?

OK.

#12 Updated by u 16 days ago

Ack.

#13 Updated by hefee 16 days ago

  • Assignee deleted (hefee)

#14 Updated by intrigeri 6 days ago

u, intrigeri I would suggest let's review sysadmin.mwdn in the repo and than after #17050, we deside where we move this stuff?

#17050 is not done but we don't necessarily have to wait for it, now that https://tails.boum.org/contribute/working_together/roles/translation_platform/operations/ exists.

I've just read translate-server.git:sysadmin.mdwn and IMO:

  • I see nothing secret (this is a cleartext Git repo that we don't host ourselves, after all).
  • I see nothing in there that should be published just for the sake of it.

However, I'm thinking of the future maintainers of this platform, and I'm convinced that their job will be more pleasurable if the operations documentation they need to use and maintain lives in one single place. Therefore, I propose we move the contents of sysadmin.mdwn to https://tails.boum.org/contribute/working_together/roles/translation_platform/operations/, fix the Markdown, and close this ticket. I volunteer to do that. Then, translate-server.git will contain only encrypted secrets, which is as lean as it can be.

Thoughts?

#15 Updated by hefee 2 days ago

  • Blocked by deleted (Bug #17050: Translation platform: design & implement long-term maintenance & support plan)

#16 Updated by hefee 2 days ago

  • Assignee set to intrigeri

intrigeri wrote:

u, intrigeri I would suggest let's review sysadmin.mwdn in the repo and than after #17050, we deside where we move this stuff?

#17050 is not done but we don't necessarily have to wait for it, now that https://tails.boum.org/contribute/working_together/roles/translation_platform/operations/ exists.

ack.

I've just read translate-server.git:sysadmin.mdwn and IMO:

  • I see nothing secret (this is a cleartext Git repo that we don't host ourselves, after all).
  • I see nothing in there that should be published just for the sake of it.

However, I'm thinking of the future maintainers of this platform, and I'm convinced that their job will be more pleasurable if the operations documentation they need to use and maintain lives in one single place. Therefore, I propose we move the contents of sysadmin.mdwn to https://tails.boum.org/contribute/working_together/roles/translation_platform/operations/, fix the Markdown, and close this ticket. I volunteer to do that. Then, translate-server.git will contain only encrypted secrets, which is as lean as it can be.

I like this idea and we can close this bug afterwards, as there is nothing to cleanup anymore.

#17 Updated by intrigeri 1 day ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF