Project

General

Profile

Bug #17062

No thumbnails in the Files browser

Added by sajolida about 1 month ago. Updated 15 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
bugfix/17062-image-thumbnails
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

In 4.0~beta2, when I open /usr/share/icons/hicolor/16x16/actions, I get no thumbnails in the Files browser.

Thumbnails should be display according to the preferences: Preferences → Search & Preview.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 9b787468 (diff)
Added by intrigeri about 1 month ago

Install libgdk-pixbuf2.0-bin, which ships the image thumbnailer used by GNOME Files (refs: #17062)

Revision e2ca3a75
Added by Sandro Knauß 15 days ago

Merge branch 'bugfix/17062-image-thumbnails' into devel (Closes: #17062)

History

#1 Updated by intrigeri about 1 month ago

  • Status changed from New to In Progress

#2 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Feature Branch set to bugfix/17062-image-thumbnails

In 4.0~beta2, when I open /usr/share/icons/hicolor/16x16/actions, I get no thumbnails in the Files browser.

Reproduced. This is a regression vs. 3.16.

Thumbnails should be display according to the preferences: Preferences → Search & Preview.

Yes, if the needed thumbnailer (libgdk-pixbuf2.0-bin) is installed. We don't have it because we don't install Recommends (which, in passing, I increasing think is a bad idea: I suspect we spend more time debugging which recommended package is missing, than we would spend maintaining a blocklist of those we don't want to ship).

#3 Updated by intrigeri about 1 month ago

  • Type of work changed from Test to Code

#4 Updated by sajolida about 1 month ago

Yes, if the needed thumbnailer (libgdk-pixbuf2.0-bin) is installed.

Installing it fixes the issue instantaneously :)

#5 Updated by intrigeri 26 days ago

#6 Updated by hefee 15 days ago

  • Assignee set to hefee

#7 Updated by Anonymous 15 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

#8 Updated by hefee 15 days ago

  • Assignee deleted (hefee)
  • % Done changed from 100 to 0

Also available in: Atom PDF