Project

General

Profile

Bug #17060

intel NUC (miniPC) needs boot parameters in order start

Added by goupille about 1 month ago. Updated 19 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17060-set-xorg-driver-for-intel-nuc
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

on an Intel NUC with an Intel Iris Plus Graphics 640, Tails starts correctly if xorg-driver=intel is added to the boot parameters.

if nomodeset is added to the startup options as well, it breaks the HDMI output (which is the only output on that computer) :

snd_hda_codec_hdmi hdaudioCOD2: no i915 binding for intel hdmi/dp codec

I wonder if that information should be added to https://tails.boum.org/gdm/ or to the known issues list in the PC section


Related issues

Related to Tails - Feature #14991: Remove /usr/share/live/config/xserver-xorg/intel.ids Resolved 11/18/2017
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 4c7eb132 (diff)
Added by segfault 29 days ago

Use the intel X.Org driver for Intel Iris Plus Graphics 640 (refs: #17060)

Revision d3ffbd04
Added by intrigeri 19 days ago

Merge remote-tracking branch 'origin/bugfix/17060-set-xorg-driver-for-intel-nuc' into devel (Closes: #17060)

History

#1 Updated by goupille about 1 month ago

the user reported that behavior with Tails 3.16 and Tails 4.0~beta1

#2 Updated by intrigeri about 1 month ago

  • Assignee changed from intrigeri to goupille

on an Intel NUC with an Intel Iris Plus Graphics 640, Tails starts correctly if xorg-driver=intel is added to the boot parameters.

We can automate this so no manual tweak by the user is needed. Please give me the corresponding PCI ID (that the user should have seen in the "fails to start" error message; otherwise, see output of lspci in the WhisperBack report) and I'll do that!

#3 Updated by intrigeri about 1 month ago

  • Category set to Hardware support
  • Assignee deleted (goupille)
  • Target version set to Tails_4.0
  • Type of work changed from End-user documentation to Code

The PCI ID we were looking for is: 8086:5926.

echo 80865926 >> config/chroot_local-includes/usr/share/live/config/xserver-xorg/intel.ids should do the trick.

#4 Updated by intrigeri about 1 month ago

#5 Updated by segfault 29 days ago

  • Related to Feature #14991: Remove /usr/share/live/config/xserver-xorg/intel.ids added

#6 Updated by segfault 29 days ago

  • Status changed from Confirmed to In Progress

#7 Updated by segfault 29 days ago

  • Assignee set to segfault
  • Feature Branch set to bugfix/17060-set-xorg-driver-for-intel-nuc

#9 Updated by goupille 25 days ago

segfault wrote:

@goupille: Do you have a way to contact the user who reported the issue? If so, could you ask them to test if this image fixes the issue for them?

According to the user, the issue is fixed with this image

#10 Updated by segfault 25 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

goupille wrote:

segfault wrote:

@goupille: Do you have a way to contact the user who reported the issue? If so, could you ask them to test if this image fixes the issue for them?

According to the user, the issue is fixed with this image

Great, thanks!

#11 Updated by intrigeri 19 days ago

  • Assignee set to intrigeri

#12 Updated by intrigeri 19 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF