Project

General

Profile

Bug #17058

Translatable unused sentences in Greeter translation

Added by xin about 1 month ago. Updated 13 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/39/commits
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Greeter

Description

In Transifex I see translation of unused sentences about the Greeter (they are in po/*.po in devel and in "Tails Misc - tails.pot" in Transifex):

-Some have the comment "This string will never be displayed in the 1st version of the greeter." It seems the second version is not under development, so can you make theses sentences untranslatable?

-others strings don't have this comment but was not used in the Greeter:
"_Windows Camouflage", "_Time Zone", "Failed to relock persistent storage." and "Relock Persistent Storage". Can you also make them unstranslatable?


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocked by Tails - Feature #16095: Curate the list of languages in Tails Greeter Resolved 11/04/2018

Associated revisions

Revision c4f9ec28 (diff)
Added by segfault 23 days ago

Remove unused camouflage related elements from greeter.ui (refs: #17058)

Revision 31afc969 (diff)
Added by segfault 23 days ago

Remove unused time zone related elements from greeter.ui (refs: #17058)

Revision ce106679 (diff)
Added by segfault 23 days ago

Remove unused camouflage related elements from greeter.ui (refs: #17058)

Revision 6cc3c38b (diff)
Added by segfault 23 days ago

Remove unused "Take a Tour" related elements from greeter.ui (refs: #17058)

Revision 005e46a3 (diff)
Added by segfault 23 days ago

Remove unused time zone related elements from greeter.ui (refs: #17058)

Revision f1f158eb (diff)
Added by segfault 23 days ago

Remove unused camouflage related elements from greeter.ui (refs: #17058)

Revision aa6f3c93 (diff)
Added by segfault 23 days ago

Remove unused "Take a Tour" related elements from greeter.ui (refs: #17058)

Revision 2b04a521 (diff)
Added by segfault 23 days ago

Remove unused time zone related elements from greeter.ui (refs: #17058)

Revision bb4f8d83 (diff)
Added by segfault 23 days ago

Remove unused camouflage related code and UI elements from Greeter (refs: #17058)

Revision e35c7672 (diff)
Added by segfault 23 days ago

Remove unused "Take a Tour" related code and UI elements from Greeter (refs: #17058)

Revision 02873394 (diff)
Added by segfault 23 days ago

Remove unused time zone related code and UI elements from Greeter (refs: #17058)

Revision 161f08a6 (diff)
Added by segfault 23 days ago

Remove unused camouflage related code and UI elements from Greeter (refs: #17058)

Revision 495690b1 (diff)
Added by segfault 23 days ago

Remove unused "Take a Tour" related code and UI elements from Greeter (refs: #17058)

Revision 96e70e3d (diff)
Added by segfault 23 days ago

Remove unused time zone related code and UI elements from Greeter (refs: #17058)

Revision eac209b1 (diff)
Added by segfault 22 days ago

Remove unused camouflage related code and UI elements from Greeter (refs: #17058)

Revision 7be09db0 (diff)
Added by segfault 22 days ago

Remove unused "Take a Tour" related code and UI elements from Greeter (refs: #17058)

Revision 2268fbe3 (diff)
Added by segfault 22 days ago

Remove unused time zone related code and UI elements from Greeter (refs: #17058)

Revision 53c6c19a
Added by intrigeri 13 days ago

Merge branch 'feature/17098-refactor-greeter' into devel (Closes: #17098, #17089, #16806, #13447, #17087, #17058, #17101, #6525, #16095, #16094, #16093)

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

  • Status changed from New to Confirmed

I think we should drop the unused bits of UI from config/chroot_local-includes/usr/share/tails-greeter/greeter.ui. If we want to be extra nice to ourselves, we can mention the corresponding commit on the tickets that are about (re-)adding these features, to save some time if/when we do so.

#3 Updated by xin 29 days ago

  • Description updated (diff)

I found other unused strings.

#4 Updated by segfault 23 days ago

  • Status changed from Confirmed to In Progress

#5 Updated by segfault 23 days ago

intrigeri wrote:

I think we should drop the unused bits of UI from config/chroot_local-includes/usr/share/tails-greeter/greeter.ui. If we want to be extra nice to ourselves, we can mention the corresponding commit on the tickets that are about (re-)adding these features, to save some time if/when we do so.

I found #10830 for the camouflage mode and #11657 for the "Take a Tour" feature, but none for the timezone setting.

#6 Updated by segfault 23 days ago

  • Status changed from In Progress to Needs Validation
  • Feature Branch set to feature/16095-curate-languages-in-greeter

Not sure if it really makes sense that I put all these Greeter related commits on the #16095 branch, but now that I started I feel like I have to go through with it.

#7 Updated by segfault 23 days ago

  • Status changed from Needs Validation to In Progress
  • Feature Branch changed from feature/16095-curate-languages-in-greeter to bugfix/17058-unused-greeter-ui-elements

There is actually code which uses these UI elements. We should delete this code too. So this not ready for review yet. I removed the commits from the #16094 branch and put them on a separate branch.

#8 Updated by segfault 23 days ago

  • Status changed from In Progress to Needs Validation

#9 Updated by segfault 23 days ago

  • Feature Branch changed from bugfix/17058-unused-greeter-ui-elements to feature/16095-curate-languages-in-greeter

I merged bugfix/17058-unused-greeter-ui-elements into feature/16095-curate-languages-in-greeter, because I plan to work some more on the Greeter on the latter branch and are afraid I would create merge conflicts.

#10 Updated by segfault 22 days ago

  • Status changed from Needs Validation to In Progress

#11 Updated by segfault 19 days ago

  • Status changed from In Progress to Needs Validation

#12 Updated by segfault 19 days ago

  • Target version set to Tails_4.0

#13 Updated by intrigeri 19 days ago

  • Assignee set to intrigeri

#14 Updated by intrigeri 19 days ago

LGTM, will now build & test.

#15 Updated by intrigeri 18 days ago

  • Blocked by Feature #16095: Curate the list of languages in Tails Greeter added

#16 Updated by intrigeri 18 days ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from intrigeri to segfault

We're done here! Please reassign to me once the branch is ready for merging.

#17 Updated by segfault 14 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Feature Branch changed from feature/16095-curate-languages-in-greeter to https://salsa.debian.org/tails-team/tails/merge_requests/39/commits

#18 Updated by intrigeri 13 days ago

  • Assignee set to intrigeri

#19 Updated by intrigeri 13 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF