Project

General

Profile

Bug #17049

Recent MacBook does not start: no boot menu, black screen

Added by intrigeri 7 months ago. Updated 11 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

This was reported on tails-testers@ on a Macbook Pro 13-inch 2017 ("Tails 4.0 beta 2" thread, starting on 2019-09-11). At my request, the reporter there nicely tested other Linux images:

The reporter (Clem Hewison <>) is happy to do more tests.

geb tells me this is a common problem on many recent MacBooks.

17049_img1.png View (1.04 MB) numbat, 01/02/2020 02:41 PM


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed
Blocked by Tails - Feature #15806: Use GRUB for USB boot on EFI 64-bit Resolved

Associated revisions

Revision 7ca99d6f
Added by intrigeri 11 days ago

Merge branch 'feature/6560-secure-boot+force-all-tests' into devel (Closes: #6560, #8415, #15806, #17049)

History

#1 Updated by intrigeri 7 months ago

#2 Updated by intrigeri 7 months ago

  • Related to Feature #15806: Use GRUB for USB boot on EFI 64-bit added

#3 Updated by intrigeri 7 months ago

  • Assignee set to intrigeri

Next steps:

  1. Have an image with GRUB (instead of syslinux) built → #15806.
  2. Ask the OP to test that image.
  3. If it still does not work, compare a Tails image with a Debian one that works and identify potentially relevant differences.
  4. Get rid of some of these differences and build candidate images.
  5. Ask testers to test new candidate images.

#4 Updated by intrigeri 7 months ago

  • Related to deleted (Feature #15806: Use GRUB for USB boot on EFI 64-bit)

#5 Updated by intrigeri 7 months ago

  • Blocked by Feature #15806: Use GRUB for USB boot on EFI 64-bit added

#6 Updated by intrigeri 7 months ago

  • Assignee changed from intrigeri to geb
  • Type of work changed from Research to Test

Clement reported that GRUB solves the problem.

geb, I'm moving this ticket to your plate so you can test the latest USB image (.img@) from https://nightly.tails.boum.org/build_Tails_ISO_feature-6560-secure-boot/lastSuccessful/archive/build-artifacts/.

#7 Updated by geb 7 months ago

geb, I'm moving this ticket to your plate so you can test the latest USB image (.img@) from https://nightly.tails.boum.org/build_Tails_ISO_feature-6560-secure-boot/lastSuccessful/archive/build-artifacts/.

ACK. I will be able to performs tests starting by the beginning of october. (The symptoms I observed weres a bit different, as it was hanging in the screen one can select the USB Stick, without going to a black screen, but maybe will it also work :) ).

#8 Updated by geb 4 months ago

Hi,

Confirmed to work on a MacBook Pro 13" 2017, which was not booting Tails at all before (hanging in UEFI menu).
(This model however, doesn't seems to have any usable drivers for trackpad / keyboard, was not working nor Tails nor on Debian Buster Live).

@intrigeri Please unassign me if you don't need more tests. I'll try to perform more in the next weeks, depending the availability of my contacts.

#9 Updated by intrigeri 4 months ago

intrigeri Please unassign me if you don't need more tests. I'll try to perform more in the next weeks, depending the availability of my contacts.

If possible, it would be nice to have a few more test results, to gain more confidence that we can generalize them, e.g. when we'll announce "we've fixed X and Y" :)

#10 Updated by goupille 3 months ago

a user reported not being able to boot Tails 4.1.1 on a 2011 macbook air (freeze after selecting the USB stick to boot on), and says that the experimental IMG fixed the issue for them

#11 Updated by goupille 3 months ago

@intrigeri : another user reported that the experimental img fixed their issue (same freeze), while another, with a look alike issue (reboot in macos recovery mode just after selecting the USB stick to boot on, with a MacBookPro15,4) said that that IMG did not fix that problem.

#12 Updated by intrigeri 3 months ago

Hi @goupille,

intrigeri : […] another, with a look alike issue (reboot in macos recovery mode just after selecting the USB stick to boot on, with a MacBookPro15,4) said that that IMG did not fix that problem.

Could you please ask us to try https://lists.autistici.org/message/20191221.150827.105ba267.en.html ?

#13 Updated by intrigeri 3 months ago

Could you please ask us to try https://lists.autistici.org/message/20191221.150827.105ba267.en.html ?

Gah, I meant "ask them", of course.

#14 Updated by goupille 3 months ago

intrigeri wrote:

Could you please ask [them] to try https://lists.autistici.org/message/20191221.150827.105ba267.en.html ?

I may have been unclear, the 3 results I gave were with people starting (or trying to) tails-amd64-feature_6560-secure-boot-4.2. the user who still have the issue reported on the 30th, were there any relevant changes since then in the img ?

#15 Updated by intrigeri 3 months ago

I may have been unclear, the 3 results I gave were with people starting (or trying to) tails-amd64-feature_6560-secure-boot-4.2. the user who still have the issue reported on the 30th, were there any relevant changes since then in the img ?

Forget it and sorry for the noise: I was confused (I thought I had pointed users to a different experimental image on this ticket).

#16 Updated by numbat 3 months ago

A user has reported: "first test", booting ends up with this error

thunderbolt 0000:07:00.0: ICM firmware is in wrong mode: 15

Screenshot attached.

Hardware details
----------------
iMac (Retina 4K, 21.5 Zoll, 2019)
3.6 Ghz Quand-core Intel Core i3
Radeon Pro 555X 2GB

#17 Updated by intrigeri about 1 month ago

Hi geb, do you think you'll be able to do more tests in the next few weeks?
If not, no big deal!

Hi @numbat, I believe the problem you've reported is different: to experience it, the user must have gone through the boot loader ⇒ please report it separately so we can close this very issue at some point, without blocking on fixing All The Things on All The Macs :)

#18 Updated by geb about 1 month ago

  • Assignee deleted (geb)

Hi,

I asked some contacts to perform some tests, but as I don't own this hardware directly, I cannot promise if/when my contacts will be able to do the tests [therefor I am removing me as assignee].

#19 Updated by geb 26 days ago

#20 Updated by intrigeri 25 days ago

Hi @geb,

https://nightly.tails.boum.org/build_Tails_ISO_feature-6560-secure-boot/lastSuccessful/archive/build-artifacts/ seems to not be available anymore, is that volontary @intrigeri ?

The branch was renamed so please now use https://nightly.tails.boum.org/build_Tails_ISO_feature-6560-secure-boot-force-all-tests/lastSuccessful/archive/build-artifacts/

(I had updated the call for testing but forgot that the URL had already been spread more broadly.)

#21 Updated by geb 16 days ago

Another test with a "MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)" : https://nightly.tails.boum.org/build_Tails_ISO_feature-6560-secure-boot/lastSuccessful/archive/build-artifacts/ boots fine (but without keyboard/trackpad support as expected), while it was not booting with the normal version.

#22 Updated by intrigeri 14 days ago

  • Assignee set to intrigeri
  • Target version set to Tails_4.5

Thank you. I'll close this issue once the branch for #15806 is merged.

And then remaining, more specific issues shall be tracked in new, dedicated tickets, rather than a catch-all-Mac-boot-problems ones :)

#23 Updated by intrigeri 11 days ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF