Project

General

Profile

Bug #17031

Test suite's otr-bot.py has obsolete dependencies

Added by intrigeri 2 months ago. Updated 2 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It's written in Python 2, which is not supposed to be included in Bullseye.

Moreover, it depends on:

  • python-jabberbot: still in Buster but won't be in Bullseye; the version in Debian is Python 2 only
  • python-xmpp: antique CVS snapshot; orphaned; on life support since years (e.g. #9074); the version in Debian is Python 2 only and therefore will likely not make it into Bullseye

So it seems like this will need to be rewritten using maintained Python 3 modules once we want to run the test suite on Bullseye.


Related issues

Related to Tails - Bug #15953: Make our test suite survive changes in the surrounding environment Confirmed 09/14/2018
Blocked by Tails - Bug #15460: Test suite broken with Java 9+ In Progress 03/27/2018

History

#1 Updated by intrigeri 2 months ago

  • Blocked by Bug #15460: Test suite broken with Java 9+ added

#2 Updated by intrigeri 2 months ago

Blocked by Bug #15460: Test suite broken with Java 9+ added

Rationale: as long as our test suite can't run on Buster, it's not worth worrying about running it on Bullseye.

#3 Updated by intrigeri 2 months ago

  • Related to Bug #15953: Make our test suite survive changes in the surrounding environment added

Also available in: Atom PDF