Project

General

Profile

Bug #17025

Persistence setup error message refers to Tails Installer

Added by intrigeri 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
bugfix/17025-tails-installer-error-message
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:

Description

When the boot device has no GPT partition table, or no partition named "Tails", the persistence setup wizard says "Device %s was not created using Tails Installer". This is misleading as the main supported ways to get Tails running on a USB stick don't rely on Tails Installer these days.

What should this message instead read?

(And from a coding perspective: both persistence-setup.git and perl5lib.git have methods with "tails_installer" in their name, which is misleading too, but at least it has no impact on users.)

History

#1 Updated by sajolida 3 months ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from sajolida to intrigeri
  • Target version set to Tails_4.0
  • Feature Branch set to bugfix/17025-tails-installer-error-message

Good catch!

What about "Device %s was not created using a USB image or Tails Installer."?

All the error messages in lib/Tails/Persistence/Setup.pm describe the problems in pretty terse way but not how to solve them, but I'll refrain myself from disgressing and fixing all of them.

Here is a branch (untested!).

#2 Updated by intrigeri 3 months ago

  • Status changed from Needs Validation to 11

Hi @sajolida,

What about "Device %s was not created using a USB image or Tails Installer."?

OK, merged. This will be shipped in the next t-p-s release, that I'll prepare during the 4.0~rc1 release process.

All the error messages in lib/Tails/Persistence/Setup.pm describe the problems in pretty terse way but not how to solve them, but I'll refrain myself from disgressing and fixing all of them.

Feel free to create another ticket for that if you'd like to: there's been quite some water under the bridge since you reviewed and rephrased all these strings 7 years ago :)

AFAICT, the only side-effects of changing these strings will be:

  • Test suite: only a problem for messages you can see in features/images/PersistenceWizard*.png
  • Fuzzy translations → better not do this too close to a release, otherwise translators won't have time to unfuzzy stuff and we'll regress on translation coverage.

#3 Updated by intrigeri about 2 months ago

  • Status changed from 11 to Resolved

Fixed in tails-persistence-setup (2.2.0-1) that will be in 4.0~rc1.

Also available in: Atom PDF