Project

General

Profile

Bug #17011

Disable GDM debug logs

Added by intrigeri 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/17011-disable-gdm-debug-logs
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

For #12092, we're going to ship with GDM debug logging enabled in 4.0~beta2, to make it easier to debug any regression introduced by that branch.
We should revert this in 4.0: config/chroot_local-hooks/30-gdm-debug.


Related issues

Related to Tails - Bug #12092: The Greeter keeps eating lots of memory after logging in Resolved 12/27/2016
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 0358ae20 (diff)
Added by intrigeri 3 months ago

Enable GDM debug logs (refs: #12092).

In case the branch for #12092 introduces regressions, we'll need debug logs to
understand when/why GDM switches VTs or $DISPLAY, and when it activates its own
logind session.

This will be reverted in refs: #17011.

Revision 9fab9914 (diff)
Added by segfault 3 months ago

Revert "Enable GDM debug logs (refs: #12092)." (refs: #17011)

This reverts commit 0358ae208acb150766e8110c225025c4bb3ed5f1.

Revision 107c6d6c (diff)
Added by segfault 2 months ago

Revert "Enable GDM debug logs (refs: #12092)." (refs: #17011)

This reverts commit 0358ae208acb150766e8110c225025c4bb3ed5f1.

Revision 5be779cf
Added by intrigeri 2 months ago

Merge remote-tracking branch 'origin/bugfix/17011-disable-gdm-debug-logs' into devel (Closes: #17011)

History

#1 Updated by intrigeri 3 months ago

  • Related to Bug #12092: The Greeter keeps eating lots of memory after logging in added

#2 Updated by intrigeri 3 months ago

#3 Updated by intrigeri 3 months ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri 3 months ago

  • Status changed from In Progress to Confirmed

#5 Updated by segfault 3 months ago

  • Status changed from Confirmed to In Progress

#6 Updated by segfault 3 months ago

  • Feature Branch set to bugfix/17011-disable-gdm-debug-logs

#7 Updated by intrigeri 3 months ago

  • Assignee set to segfault

#8 Updated by intrigeri 2 months ago

Hi segfault! Shall I review this? Or is there anything we're waiting for?

#9 Updated by segfault 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from segfault to intrigeri

Hi segfault! Shall I review this?

Yes, this is ready for review.

#10 Updated by intrigeri 2 months ago

Thanks! I'll first handle my backlog of 4.0~beta2 feedback, to ensure that there's been no regression caused by #12092, that would justify keeping this debug logging around.

#11 Updated by intrigeri 2 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF