Project

General

Profile

Bug #17008

Ensure we don't upgrade systemd to v243+ without fixing the haveged incompatibility

Added by intrigeri 3 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
Build system
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

See https://bugs.debian.org/938939 and https://salsa.debian.org/debian/haveged/merge_requests/1.

Our options:

  • Cross fingers and hope we'll notice if we pull systemd v243+ from backports in Tails 4.x, or when we'll be preparing 5.0. Hmm…
  • Add a comment in our apt/preferences, in the place where one would add the systemd section? Not really satisfying but possibly good enough.
  • Add a build-time hook that says "ensure you also get a fix for #NNNNN and then delete this hook" + exit 1, if systemd >= 243.

kibi and I prefer the last option.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by intrigeri 3 months ago

Also available in: Atom PDF