Project

General

Profile

Bug #17004

Update test suite to cope with Unsafe Browser homepage changes

Added by intrigeri 24 days ago. Updated 18 days ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
test/17004-unsafe-browser-homepage-stretch, test/17004-unsafe-browser-homepage-buster
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Unsafe Browser

Description

wiki/src/misc/unsafe_browser_warning.html has been changed today on master and devel, in a way that sometimes breaks the test suite.

We need to:

  1. Merge master into stable.
  2. Fork a branch off stable.
  3. On that branch, update features/images/UnsafeBrowserStartPage.*.png.
  4. Ensure this fixes the problem: the "The Unsafe Browser can be used in all languages supported in Tails" scenario should pass without leaving fuzzy Sikuli candidates behind.
  5. Review and merge into stable.
  6. Merge stable into devel.
  7. Update the pictures again on devel: the page is rendered differently on Buster.
  8. Ensure this fixes the problem on devel too: the "The Unsafe Browser can be used in all languages supported in Tails" scenario should pass without leaving fuzzy Sikuli candidates behind.

Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision cf83fb2b (diff)
Added by intrigeri 23 days ago

Test suite: don't hard-code the list of locales that have a translated Unsafe Browser homepage (refs: #17004).

This list will change. For example, right now, no language has any
such translation, since the homepage was just fully rewritten.
When a language gets a translation, we can add a picture.
When a language loses its translation, we can remove the picture.
In both cases, we should not have to modify this step definition.

Revision 396b0ead (diff)
Added by intrigeri 23 days ago

Test suite: remove localized pictures of the Unsafe Browser homepage (refs: #17004)

No language has this translated at the moment.

Revision 0156e8dc (diff)
Added by intrigeri 23 days ago

Test suite: update expected picture for the Unsafe Browser homepage (refs: #17004)

This is the version for Buster. The version for Stretch may differ.

Revision e09ce396 (diff)
Added by intrigeri 23 days ago

Test suite: update expected picture for the Unsafe Browser homepage (refs: #17004)

This is the Stretch version. It differs from the Buster version.

Revision 3de25862
Added by Sandro Knauß 22 days ago

Merge branch 'test/17004-unsafe-browser-homepage-stretch' into stable (fix-committed: #17004)

History

#1 Updated by intrigeri 24 days ago

#2 Updated by intrigeri 23 days ago

  • Assignee set to intrigeri

#3 Updated by intrigeri 23 days ago

  • Status changed from Confirmed to In Progress

#4 Updated by intrigeri 23 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)
  • Feature Branch set to test/17004-unsafe-browser-homepage-stretch, test/17004-unsafe-browser-homepage-buster

Please review and merge:

  • test/17004-unsafe-browser-homepage-stretch into stable
  • test/17004-unsafe-browser-homepage-buster into devel

I've already merged the former into the latter, to ensure we resolve the merge conflict in favor of the Buster image for devel.

I've run the affected scenario locally (The Unsafe Browser can be used in all languages supported in Tails) from each branch, respectively on an ISO built from stable and one built from devel. Passed with flying colors.

#5 Updated by intrigeri 23 days ago

  • Assignee set to hefee

@hefee, can you handle this one by the end of the week?

#6 Updated by intrigeri 23 days ago

  • Status changed from Needs Validation to In Progress

#7 Updated by intrigeri 23 days ago

  • Status changed from In Progress to Needs Validation

Meh.

#8 Updated by Anonymous 22 days ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 0 to 100

#9 Updated by CyrilBrulebois 18 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF