Project

General

Profile

Bug #16989

Enable voting for Weblate users

Added by hefee about 1 month ago. Updated 5 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
salsa.debian.org:/hefee/puppet-tails.git:hefee/enable-voting
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:
Translation Platform

Description

I implemented now sorting suggestions based on the votes they have (#16932), there is now a good reason, why we want voting enabled for users.

Please do not mix this auto_accept by votes, that is something different.

What we need to change:

Normal users needs to be able to vote on suggestions, not only reviewers.
All components need suggestion_voting=True and suggestion_autoaccept=0 (this disables autoaccept by voting)

I enabled suggestion_voting=True already for wiki/src/sandbox.mwdn for testing purpose.


Related issues

Related to Tails - Bug #16855: Enforce reviewer policy on Weblate Resolved
Related to Tails - Feature #16932: Weblate staging website: improve algorithm that chooses among available suggestions Resolved

History

#1 Updated by hefee about 1 month ago

  • Related to Bug #16855: Enforce reviewer policy on Weblate added

#2 Updated by hefee about 1 month ago

  • Related to Feature #16932: Weblate staging website: improve algorithm that chooses among available suggestions added

#3 Updated by intrigeri 10 days ago

This sounds good to me. Is this all something that needs to be done in our Python scripts, or is there anything else to do? Do you want to implement it yourself?

#4 Updated by hefee 6 days ago

  • Assignee set to hefee

Well it needs two things:
- Update the python scripts & update all components according to the new setting.

#5 Updated by hefee 6 days ago

  • Assignee changed from hefee to intrigeri
  • Feature Branch set to salsa.debian.org:/hefee/puppet-tails.git:hefee/enable-voting

The script to apply after puppet was updated in (~weblate/scripts) I would use ipython3:

import tailsWeblate
subProjects = tailsWeblate.models.SubProject.objects.all()
for project in subProjects:
    project.suggestion_voting = True
    project.suggestion_autoaccept = 0
    project.save()

#6 Updated by intrigeri 5 days ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from intrigeri to hefee

The script to apply after puppet was updated in (~weblate/scripts) I would use ipython3:

I've merged & deployed your branch + I've run this code.

Please check that I got it right, test that it works as intended, and then I guess we can close this ticket :)

#7 Updated by hefee 5 days ago

  • Status changed from Needs Validation to Resolved
  • Assignee deleted (hefee)

Please check that I got it right, test that it works as intended, and then I guess we can close this ticket :)

I checked by script ans looked in the interface if I'm able to up/down-vote seems fine.

The test script I used:

import tailsWeblate
subProjects = tailsWeblate.models.SubProject.objects.all()
for project in subProjects:
    if p.suggestion_voting != True:
        print(p)
    if p.suggestion_autoaccept != 0:
        print(p)

Also available in: Atom PDF