Project

General

Profile

Bug #16988

MAC spoofing not disabled in 4.0~beta1

Added by sajolida about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Spoof MAC
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

  • Start Tails 4.0~beta1 on my spare X201.
  • Disable MAC spoofing in Tails Greeter.
  • Start Tails.
  • macchanger -s wlan0

I get a different "Current MAC" and "Permanent MAC".


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

Interesting! Especially given we have an automated test about this. Perhaps something different happens for Wi-Fi devices? E.g. could it be NetworkManager's MAC address randomization while scanning for networks?

#3 Updated by intrigeri about 1 month ago

  • Assignee set to sajolida

E.g. could it be NetworkManager's MAC address randomization while scanning for networks?

According to my test, that's exactly it, and it's expected since Tails 3.0.

Dear sajolida, please try this:

  1. Start Tails 4.0~beta1
  2. Disable MAC spoofing in Tails Greeter.
  3. Start Tails.
  4. macchanger -s wlan0 → you get a different "Current MAC" and "Permanent MAC", as expected (for details, see 30dd0e10a0f58cd6d6e6a5e859ca52c5b2ecdefe and #11856)
  5. Connect to a Wi-Fi network
  6. macchanger -s wlan0 → you should get "Current MAC" == "Permanent MAC"; if you get different MAC addresses at this point, then it's a bug and I'll need a WhisperBack report to investigate further as I can't reproduce it; if you get identical MAC addresses at this point, then it's a feature, and please close this ticket as not-a-bug (Rejected)

Thanks in advance!

#4 Updated by sajolida about 1 month ago

  • Status changed from New to Rejected
  • Assignee deleted (sajolida)

Indeed, sorry for the noise: the MAC address gets back the the permanent one. Case closed.

#5 Updated by intrigeri about 1 month ago

Indeed, sorry for the noise: the MAC address gets back the the permanent one. Case closed.

Thanks for confirming! :)

Also available in: Atom PDF