Project

General

Profile

Feature #16981

Have to scroll to see all "Utilities"

Added by sajolida about 1 month ago. Updated 26 days ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
feature/16981-tweak-gnome-app-menu
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

As reported on tails-testers ("Opinion about Tails 4.0beta1"). See screenshot in attachment.

This is due to 2 applications moving from other submenus into the "Utilities" submenu:

  • Calculator from Accessories to Utilities
  • Terminal from System Tools to Utilities

When doing usability tests, people don't really make a semantical difference between "Accessories", "System Tools", and "Utilities". When they can't find what they are looking for on the first try, they do an extensive search through as many submenus as needed.

I propose to move back "Calculator" and "Terminal" to where they were in 3.0, which wasn't so bad and prevented this problem, which I think is worse: people have to do more complex interactions than scanning the submenus in the right column to see all the available possibilities correctly.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision be158576 (diff)
Added by segfault 27 days ago

Move some GNOME apps to different menu categories (refs: #16981)

This moves Calculator to Accessories and Terminal to System Tools,
by deleting the respective Include and Exclude lines in
/etc/xdg/menus/gnome-applications.menu.

Revision d954d521
Added by intrigeri 26 days ago

Merge remote-tracking branch 'origin/feature/16981-tweak-gnome-app-menu' into devel (Closes: #16981)

History

#1 Updated by intrigeri about 1 month ago

#2 Updated by intrigeri about 1 month ago

  • Priority changed from Normal to Elevated

#3 Updated by intrigeri about 1 month ago

Note to whoever will work on this.

The .desktop file for GNOME Terminal has "System", not "Utilities", so I'm confused. I've tried the basics for a while (by editing the .desktop file, e.g. X-GNOME-System) and could not make it work after sudo xdg-desktop-menu forceupdate and gnome-shell --replace. Maybe something else is cached at build time and one could try building an ISO.

The relevant code seems to be in GNOME Shell's js/ui/appDisplay.js that calls Gio.AppInfo.get_all().

I did not check online nor in the doc.

#4 Updated by segfault 27 days ago

  • Assignee set to segfault

#5 Updated by segfault 27 days ago

  • Assignee deleted (segfault)

I spent quite a lot of time figuring this one out. The categories the GNOME applications are put in are hardcoded in /etc/xdg/menus/gnome-applications.menu. So the only way I see to change the categories of the GNOME apps is to patch that file. It's a huge XML file. I can create a patch, but I'm not sure if we really want to maintain that patch.

FWIW, I also tried to change the category using xdg-desktop-menu install and xdg-desktop-menu uninstall, but it didn't work.

#6 Updated by segfault 27 days ago

  • Status changed from Confirmed to In Progress

#7 Updated by segfault 27 days ago

  • Assignee set to segfault

#8 Updated by segfault 27 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

Created a patch, built and tested it.

#9 Updated by intrigeri 27 days ago

  • Assignee set to intrigeri

Wow, congrats segfault for figuring this one out! I'm fine with the approach you've picked: AFAICT we'll only have to update this patch when we upgrade the gnome-menus package, which rarely happens.

LGTM. Before merging, I'll test this in a couple locales to make sure this applies regardless of the language.

#10 Updated by intrigeri 26 days ago

  • Feature Branch set to feature/16981-tweak-gnome-app-menu

#11 Updated by intrigeri 26 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF