Project

General

Profile

Bug #16946

Optimize SquashFS for currently supported use cases

Added by intrigeri about 2 months ago. Updated 20 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

We still optimize (sort) the SquashFS for bare metal DVD, while nowadays:

  • ISO images are supported for VMs only.
  • Everyone else should use the USB image.

So let's instead optimize for bare metal USB sticks, i.e. the most common real-world use case. I doubt it'll harm performance for VMs (an internal hard drive is very different from a bare metal DVD drive anyway).


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

History

#1 Updated by intrigeri about 2 months ago

#2 Updated by intrigeri 20 days ago

  • Status changed from Confirmed to Resolved

Meh, this was done months ago, in 5273b9cf0545c6148275f3d547bab11d6e92c8e5, so we're already supposed to optimize our SquashFS for USB drives. So I don't understand why anonym asked me why we did not do this exact change, while he was releasing 4.0~beta1.

FTR, I've left the DVD burner part in contribute/working_together/roles/release_manager because pretty often, no manual tester has the hardware for the "Boot on bare-metal from DVD" test, so it makes sense to ensure each RM is able to do that test as a fallback: assuming the RM reads the "In the beginning of your shift" section in the beginning of their shift, they have 6-9 weeks to find the needed hardware, while manual testers have much less time.

Also available in: Atom PDF