Project

General

Profile

Feature #16924

Feature #16096: Donation campaign 2019

Tweet about the donation campaign

Added by sajolida 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
donors.git:2019-tweets.mdwn
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

Now that we know how to schedule them we can tweet more.

It will also be easier to tweet in more languages.

History

#1 Updated by sajolida 4 months ago

  • Assignee set to sajolida

#2 Updated by sajolida 3 months ago

  • Status changed from New to Confirmed

#3 Updated by intrigeri 3 months ago

  • Target version changed from Tails_3.17 to Tails_4.0

#4 Updated by sajolida 2 months ago

  • Status changed from Confirmed to Needs Validation
  • Assignee deleted (sajolida)
  • Feature Branch set to donors.git:2019-tweets.mdwn

Ready for review!

I even drafted a timeline on when to send each tweet (2019-timeline.ods) so we can schedule them all at once at the beginning :)

#5 Updated by intrigeri 2 months ago

  • Assignee set to intrigeri

#6 Updated by intrigeri 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from intrigeri to sajolida

I've pushed minor changes. In general I find all this great! Here are a few comments:

Elsewhere I see you've used https://tails.boum.org/donate?r=xyz, while here you use https://tails.boum.org/donate?xyz. I suggest making this consistent, at least so that nobody like me wonders which one is correct.

Also, in some cases you add ?r=xyz when pointing to blog posts, and in other cases you don't. If there's a good reason for this, don't bother explaining me why. If there's no good reason for this, well, now you know :)

Wrt. t-shirts: "until the end of our donation campaign" ← can we really commit to this? Isn't there a chance that we run out of t-shirts earlier?

Wrt. "anonymously", I'd like to make sure you are very confident about the anonymity properties of Monero, Zcash, and Stellar: our voice is trusted by many and if we endorse this, I'm pretty sure a bunch of folks will believe it without checking themselves.

"Donate now to fund more improvements in 2020: https://tails.boum.org/news/achievements_in_2019" feels weird: I would expect a link to our plans for 2020 instead.

"They will be though." ← I can't parse this sentence.

#7 Updated by sajolida 2 months ago

Elsewhere I see you've used https://tails.boum.org/donate?r=xyz, while here you use https://tails.boum.org/donate?xyz. I suggest making this consistent, at least so that nobody like me wonders which one is correct.

Oops, fixed in 0bfd304 :)

Also, in some cases you add ?r=xyz when pointing to blog posts, and in other cases you don't. If there's a good reason for this, don't bother explaining me why. If there's no good reason for this, well, now you know :)

Fixed in 0bfd304 as well.

Wrt. t-shirts: "until the end of our donation campaign" ← can we really commit to this? Isn't there a chance that we run out of t-shirts earlier?

Right, and it won't bring much benefit to promise this anyway, so I
removed it in 7317cda.

Wrt. "anonymously", I'd like to make sure you are very confident about the anonymity properties of Monero, Zcash, and Stellar: our voice is trusted by many and if we endorse this, I'm pretty sure a bunch of folks will believe it without checking themselves.

Right. Monero and Zcash are designed to fix the anonymity issues of
Bitcoin, so we're only repeating their promises here. But it's not the
case for Stellar. Fixed in 6d58278.

"Donate now to fund more improvements in 2020: https://tails.boum.org/news/achievements_in_2019" feels weird: I would expect a link to our plans for 2020 instead.

This tweet is meant to announce our blog post on achievements, that's
before the blog post on plans so I can link to it. I tried to clarify
the expected link in 8657438.

"They will be though." ← I can't parse this sentence.

moire fixed it :) It's 'tough'.

#8 Updated by sajolida about 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Today I scheduled 12 tweets using Tweetdeck. I didn't schedule the tweets on the other blog posts because we're not exactly sure of their timing yet.

Also available in: Atom PDF