Project

General

Profile

Feature #16920

Feature #16096: Donation campaign 2019

Prepare the banner for the donation campaign

Added by sajolida 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
web/16920-donation-banner
Type of work:
Website
Blueprint:
Starter:
Affected tool:

History

#1 Updated by sajolida 4 months ago

  • Assignee set to sajolida

#2 Updated by intrigeri 3 months ago

  • Target version changed from Tails_3.17 to Tails_4.0

#3 Updated by sajolida 3 months ago

  • Subject changed from Prepare the donation banner to Prepare the banner for the donation campaign
  • Status changed from Confirmed to Needs Validation
  • Assignee deleted (sajolida)
  • Feature Branch set to web/16920-donation-banner

The same as last year, minus the counter.

#4 Updated by sajolida 2 months ago

  • Assignee set to u

#5 Updated by u 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from u to sajolida

Looks mostly good with some questions from my side.

For the upper banner:

- can we have translations in IT and PT? The second sentence is not translated.
- what is the accounts.fods file? I did not understand
- why did you reenable the JS, that has outdated information and outdated code:

  var endOfCampaign = new Date("2019-01-15");

The counter is not present anywhere besides in the two files:

fgrep -r counter-number-of-days *
config/chroot_local-includes/usr/share/doc/tails/website/donate-banner.js:  var numberOfDays = document.getElementsByClassName('counter-number-of-days');
wiki/src/donate-banner.js:  var numberOfDays = document.getElementsByClassName('counter-number-of-days');

for the banner on /home

- "But, not everyone can donate." → i would delete the comma and not underline the text, as it looks like a link. Maybe have the background of this sentence purple instead? I remember having had the same discussion last year somehow :)

- "When you donate, you are offering to many others who need it, this precious tool that is Tails." This sentence does not follow the Orwell simplicity writing advice :) Do you think we can make that simpler?

#6 Updated by sajolida 2 months ago

- can we have translations in IT and PT? The second sentence is not translated.

I was waiting for your review to call for translations to update various
bits.

- what is the accounts.fods file? I did not understand

Oops! It's the file that I used to update the counter last year but this
year we won't have any. Fixed in 2bc21e55e5.

- why did you reenable the JS, that has outdated information and outdated code:

Because of mistake :) Fixed in 2bc21e55e5.

for the banner on /home

- "But, not everyone can donate." → i would delete the comma

I'm pretty sure that Cody asked for this comma during a review (even
though I'm the author of 9f3516258e).

and not underline the text, as it looks like a link. Maybe have the background of this sentence purple instead? I remember having had the same discussion last year somehow :)

The exact same code didn't trigger any discussion last year but
triggered one when working on #14559#21. Anyway, I removed the
underlining as we did in #14559.

- "When you donate, you are offering to many others who need it, this precious tool that is Tails." This sentence does not follow the Orwell simplicity writing advice :) Do you think we can make that simpler?

It's been reviewed by moire, Cody, and translated in several languages
already. Feel free to propose something better if you think that it's
really worth it to change now.

Other than that, I think that we're good on this branch.

Thanks for the prompt review!

#7 Updated by sajolida 2 months ago

  • Status changed from In Progress to 11
  • Assignee deleted (sajolida)

Marking as "Fix committed".

@u might still propose an improvement on "When you donate [...]".

#8 Updated by sajolida about 2 months ago

  • Status changed from 11 to Resolved

Launched today!

Also available in: Atom PDF