Project

General

Profile

Feature #16903

Refactor tails-documentation

Added by segfault 9 months ago. Updated 23 days ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
feature/16903-refactor-tails-documentation
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

While working on #16664, I had to change a line in tails-documentation, and I couldn't help but refactor it.


Related issues

Blocked by Tails - Feature #16664: Simplify "Tor has bootstrapped" status check Resolved

Associated revisions

Revision 4e02f0d1 (diff)
Added by segfault 9 months ago

Refactor tails-documentation (refs: #16903)

Revision 3434d9ac (diff)
Added by segfault 30 days ago

Refactor tails-documentation (refs: #16903)

Revision 5484d706
Added by intrigeri 23 days ago

Merge remote-tracking branch 'origin/feature/16903-refactor-tails-documentation' into devel (Closes: #16903)

History

#1 Updated by segfault 9 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by segfault 9 months ago

  • Feature Branch set to feature/16903-refactor-tails-documentation

#3 Updated by segfault 9 months ago

  • Blocked by Feature #16664: Simplify "Tor has bootstrapped" status check added

#4 Updated by segfault 9 months ago

Blocked by #16664 because I use tor_has_bootstrapped from tailslib.tor, which can only be used by amnesia after changes I made in #16664.

#5 Updated by segfault 9 months ago

  • Assignee set to segfault

#6 Updated by segfault about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Target version set to Tails_4.5

segfault wrote:

Blocked by #16664 because I use tor_has_bootstrapped from tailslib.tor, which can only be used by amnesia after changes I made in #16664.

#16664 was merged so this is not blocked anymore. I also tested again that tails-documentation still works as expected.

#7 Updated by intrigeri about 1 month ago

  • Status changed from Needs Validation to In Progress
  • Assignee set to segfault

Hi! It looks like the branch suffered from a buggy rebase: it includes duplicate commits, that we already have on the stable branch. Perhaps all we need is a branch forked off stable, with 4e02f0d1e25c1ec7bd2e80057958a1f9fbdaf114 cherry-picked on top?

#8 Updated by segfault 30 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)

intrigeri wrote:

Hi! It looks like the branch suffered from a buggy rebase: it includes duplicate commits, that we already have on the stable branch. Perhaps all we need is a branch forked off stable, with 4e02f0d1e25c1ec7bd2e80057958a1f9fbdaf114 cherry-picked on top?

Huh, I wonder how that happened. Anyway, fixed it now.

#9 Updated by intrigeri 24 days ago

  • Assignee set to intrigeri

#10 Updated by intrigeri 24 days ago

Code LGTM! This script is used in various places and I'm not sure if any affected test is tagged fragile, so I'll run the full test suite locally. It seems that we have great automatic test coverage and I assume segfault tested this manually already, so I'll skip manual testing (worst case, there's a chance that any problem is spotted in 4.5~rc1).

Despite the overhead that makes the total short-term cost/benefit look pretty high, I'm glad you're setting the bar higher wrt. code quality/style: having good examples will help new contributors write better code :)

#11 Updated by intrigeri 23 days ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF