Project

General

Profile

Feature #16901

Only scrub HTML on blueprints

Added by sajolida 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
web/16901-only-scrub-blueprints
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

On all the pages of the website that we wrote lately and that needed some special look, we had to disable the htmlscrubber plugin of ikiwiki through the htmlscrubber_skip configuration variable of ikiwiki.

For example:

This is mostly due to the fact that htmlscrubber disallows the use of custom style sheets but also to be able to add some JavaScript.

Custom style sheets are useful to customize specific pages while preventing local.css to go wild.

I'm tired of editing htmlscrubber_skip each time and having to ask our sysadmins to edit it. See #16540 for a painful example of that.

htmlscrubber was initially enabled on all the website because all pages were publicly editable. Now that only blueprints are editable, I propose to only disable htmlscrubber on all the website except blueprints.

0001-Test-for-web-16901-only-scrub-blueprints.patch View (1.71 KB) sajolida, 07/20/2019 09:14 PM

Associated revisions

Revision 79615b7e (diff)
Added by sajolida 5 months ago

Only scrub HTML on blueprints (Will-fix: #16901)

Revision 2c21b016
Added by intrigeri 4 months ago

Merge remote-tracking branch 'origin/web/16901-only-scrub-blueprints'

Fix-committed: #16901

History

#1 Updated by sajolida 5 months ago

  • Status changed from Confirmed to In Progress

#2 Updated by sajolida 5 months ago

Here is a branch.

You can test it with the patch in attachment. Pages that are not scrubbed turn red. Pages that are scrubbed don't turn red :)

Once the branch has been validated we should ask our sysadmins to apply this change on the production website.

#3 Updated by sajolida 5 months ago

It gives a 3% improvement on the build time.

#4 Updated by intrigeri 4 months ago

  • Assignee set to intrigeri

#5 Updated by intrigeri 4 months ago

  • Status changed from Needs Validation to 11
  • % Done changed from 0 to 100

#6 Updated by intrigeri 4 months ago

  • Status changed from 11 to Resolved
  • % Done changed from 100 to 0

Merged and applied the same change on our production website. I'll let you update #16540 accordingly.

Also available in: Atom PDF