Project

General

Profile

Feature #16892

Allow moire to see Fundraising tickets that are not assigned to him

Added by sajolida 3 months ago. Updated 17 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Fundraising
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

From what I understood from the meeting yesterday, moire can only see private tickets that are assigned to him.

Lately, we've been using private tickets a lot for fundraising tasks and I don't want to change this.

Having moire only able to see his tickets limits the extent to which he can learn about what other people in the team are doing and possibly help on tickets that are not assigned to him (since we can't assign tickets to several people). For example, I wanted to point him to #16879 but I can't do that because it's assigned to Ulrike.

How can we improve on that?

Grant him admin rights on Redmine?


Related issues

Related to Tails - Feature #16216: Setup a funding opportunities calendar Confirmed 12/10/2018

History

#1 Updated by intrigeri 3 months ago

From what I understood from the meeting yesterday, moire can only see private tickets that are assigned to him.

This is also my understanding.

Lately, we've been using private tickets a lot for fundraising tasks and I don't want to change this.

Agreed.

Having moire only able to see his tickets limits the extent to which he can learn about what other people in the team are doing and possibly help on tickets that are not assigned to him (since we can't assign tickets to several people). For example, I wanted to point him to #16879 but I can't do that because it's assigned to Ulrike.

I acknowledge this is a serious problem.

How can we improve on that?

Grant him admin rights on Redmine?

I think "Manager" would be sufficient. This would imply moire has the same access to private info as, for example, accounting team members (and satisfy the corresponding security policy). It could be a solution but this needs to go through our decision-making process on tails@. I'm fine with that.

However, note that this will hopefully be a short-lived problem: the proposal I'll send to our team soonish (likely in August), to migrate all Fundraising tickets to a private GitLab project, will give all Fundraising team members equal access to the team's tickets (as discussed at the accounting sprint in Leipzig, so we have a Kanban etc). So perhaps it's not worth bothering fixing this problem right now. I could propose, for example, that we put this on the backburner until the end of August, and if by then, I've not managed to migrate fundraising stuff to GitLab, then we start the aforementioned decision making process to give moire more elevated credentials on Redmine.

#2 Updated by sajolida 3 months ago

  • Status changed from New to Confirmed
  • Target version set to Tails_3.16

I'm fine with that.

Hopefully the next step will be done by you in the GitLab proposal so let's keep this assigned to you and target 3.16 (September 3).

By 3.16 we'll now if moving to GitLab is feasible or if we should raise the topic on tails@.

#3 Updated by intrigeri 2 months ago

  • Related to Feature #16216: Setup a funding opportunities calendar added

#4 Updated by intrigeri about 2 months ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails_3.16 to Tails_3.17

sajolida wrote:

Hopefully the next step will be done by you in the GitLab proposal

Proposal sent!

By 3.16 we'll now if moving to GitLab is feasible

I think I'd like u's opinion on the GitLab migration proposal, so 3.16 might be tough.

#5 Updated by intrigeri about 1 month ago

  • Type of work changed from Sysadmin to Discuss

It's now clear that the GitLab option will not solve this problem in a timely manner, so as promised here about 2 months ago, I'm falling back to the only option on the table that I find realistic: giving moire access to all our Redmine tickets, including private ones.

Accordingly, I've just sent a "Giving Fundraising team members access to fundraising tickets (#16892)" proposal to tails@.

#6 Updated by intrigeri about 1 month ago

  • Target version changed from Tails_3.17 to Tails_4.0

#7 Updated by intrigeri 29 days ago

Note to myself: deadline for the proposal is Sept 24.

#8 Updated by intrigeri 17 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to moire

@moire, you should now be able to see our private tickets and notes. For example, on https://redmine.tails.boum.org/code/projects/tails/issues?query_id=322 I currently see 47 tickets. Last time we checked together, you could only see half of them or so. Can you please try again?

#9 Updated by moire 17 days ago

  • Status changed from Needs Validation to Resolved

intrigeri wrote:

@moire, you should now be able to see our private tickets and notes. For example, on https://redmine.tails.boum.org/code/projects/tails/issues?query_id=322 I currently see 47 tickets. Last time we checked together, you could only see half of them or so. Can you please try again?

@intrigeri I now see 47 tickets there. Looks like it works, thanks!

Also available in: Atom PDF