Project

General

Profile

Bug #16850

Test suite: switch to another testing OpenPGP key

Added by intrigeri about 2 months ago. Updated 20 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

dkg's key was attacked and chances are that our scenarios, that use it, are affected. We probably need to switch to another key.


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed 03/22/2019

History

#1 Updated by intrigeri about 2 months ago

#2 Updated by segfault 23 days ago

intrigeri wrote:

dkg's key was attacked and chances are that our scenarios, that use it, are affected. We probably need to switch to another key.

We're not affected, because we don't use the attacked key (0xc4bc2ddb38cce96485ebe9c2f20691179038e5c6). We use dkg's old key (0x0ee5be979282d80b9f7540f1ccd2ed94d21739e9). He switched keys in January 2019 (https://dkg.fifthhorseman.net/blog/2019-dkg-openpgp-transition.html).

The old key is expired since 2019-06-29, but the tests we use it for don't require the key to be valid, so I don't see a need to switch to another key.

#3 Updated by intrigeri 20 days ago

  • Status changed from Confirmed to Rejected

Thanks, @segfault!

Also available in: Atom PDF