Project

General

Profile

Feature #16846

Include magic wormhole

Added by mjcj 4 months ago. Updated about 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Include magic wormhole with the OS.
It is already available as an install package with most Linux distributions. It is a handy way to get files or information from one computer to another.

From: https://github.com/warner/magic-wormhole
"Get things from one computer to another, safely.
This package provides a library and a command-line tool named wormhole, which makes it possible to get arbitrary-sized files and directories (or short pieces of text) from one computer to another. The two endpoints are identified by using identical "wormhole codes": in general, the sending machine generates and displays the code, which must then be typed into the receiving machine.
The codes are short and human-pronounceable, using a phonetically-distinct wordlist. The receiving side offers tab-completion on the codewords, so usually only a few characters must be typed. Wormhole codes are single-use and do not need to be memorized."

More detailed docs on the project are available here: https://magic-wormhole.readthedocs.io/en/latest/

History

#1 Updated by sajolida 3 months ago

  • Assignee set to mjcj
  • Type of work changed from Debian to Code

Hi @mjcj, I don't remember seeing you name on Redmine already, so welcome and thanks for the proposal!

Right now we already have Onion Share in Tails, see https://tails.boum.org/doc/anonymous_internet/onionshare/.

From what I read about Magic Wormhole (I never used it myself), it seems to fulfill the same user goals as Onion Share:

As a user I want to send a file to someone else in a secure way and I already have another secure communication channel to exchange a secret address.

What user problems would Magic Wormhole solves that Onion Share is not solving? For example, is it possible for the receiving end to download the file even after the sending end went offline?

Also, Magic Wormhole is currently only a command line tool. When choosing priorities for the best interests of our users, we always favor tools that have a user interface over command line tools.

Since I see that Magic Wormhole is already in Debian, more tech-savvy people can already install it using the Additional Software feature: https://tails.boum.org/doc/first_steps/additional_software/

Did you try Magic Wormhole in Tails already? Does it work?

#2 Updated by mjcj about 2 months ago

One advantage it has over Onion Share is that you can easily communicate the secret required to retrieve a file or message verbally. For example, '7-eskimo-tactics'
Also, under normal circumstances, it will establish a direct connection between the sender and receiver over the local network for the data transfer, if possible, instead of sending data out over the internet. It does require both the sender and receiver to be online at the same time.

I finally had some time to test it out and unfortunately, it doesn't seem to work through tor. It appears as though a required connection to a Rendezvous server fails. I'm not sure if it is due to an exit node blocking traffic or some filtering that is enabled on the Rendezvous servers that are currently supporting Magic Wormhole.

Regardless of the cause of the failure, this request should be probably closed until it functions properly on Tails.

#3 Updated by intrigeri about 2 months ago

  • Status changed from New to Rejected

One advantage it has over Onion Share is that you can easily communicate the secret required to retrieve a file or message verbally. For example, '7-eskimo-tactics'

Oh, interesting!

I finally had some time to test it out and unfortunately, it doesn't seem to work through tor. It appears as though a required connection to a Rendezvous server fails. I'm not sure if it is due to an exit node blocking traffic or some filtering that is enabled on the Rendezvous servers that are currently supporting Magic Wormhole.

Thanks a lot for investigating feasibility further. Too bad it does not work :/

Regardless of the cause of the failure, this request should be probably closed until it functions properly on Tails.

Agreed, doing this now.

Also available in: Atom PDF