Project

General

Profile

Bug #16823

Upgrade Linux to 4.19.37-4+

Added by intrigeri 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/16823-linux-4.19.37-4+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 6f78ce38 (diff)
Added by intrigeri 8 months ago

Bump APT snapshot of the Debian archive to 2019061901 (refs: #16823)

It brings linux 4.19.37-4.

Revision fe81e7e3
Added by anonym 8 months ago

Merge remote-tracking branch 'origin/bugfix/16823-linux-4.19.37-4+force-all-tests' into stable

Fix-committed: #16823

History

#1 Updated by intrigeri 8 months ago

#2 Updated by intrigeri 8 months ago

  • Description updated (diff)

#3 Updated by intrigeri 8 months ago

  • Target version changed from Tails_3.15 to Tails_3.14.1

(If ready in time. Won't block/delay 3.14.1 for this.)

#4 Updated by intrigeri 8 months ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to bugfix/16823-linux-4.19.37-4+force-all-tests

#5 Updated by intrigeri 8 months ago

If bumping the APT snapshot like I did so far ends up being an OK solution, we'll need to bump its expiration time.

#6 Updated by intrigeri 8 months ago

Bumping the "debian" APT snapshot pulls these upgrades:

… on top of current stable.

#7 Updated by intrigeri 8 months ago

intrigeri wrote:

If bumping the APT snapshot like I did so far ends up being an OK solution, we'll need to bump its expiration time.

Optimistically done this.

#8 Updated by intrigeri 8 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to anonym

Full test suite run locally passed except:

  • #16825 made 11 scenarios fail their After hook which checks for Tor leaks; I think the risk that this branch introduces new Tor leaks is very low but still, this is worrying.
  • Electrum, as expected
  • Most of features/torified_gnupg.feature failed; it may be that my test system has trouble connecting to keyservers today.

The run on Jenkins started only 2h ago so it won't give us additional data points.

@anonym, I'll let you make the go/no-go decision. Either way, I don't think we should delay 3.14.1 due to this ticket so I'm not going to re-run failing scenarios. I'm busy elsewhere anyway.

#9 Updated by anonym 8 months ago

  • Status changed from Needs Validation to 11
  • % Done changed from 0 to 100

#10 Updated by anonym 8 months ago

  • Assignee deleted (anonym)

intrigeri wrote:

Full test suite run locally passed except:

  • #16825 made 11 scenarios fail their After hook which checks for Tor leaks; I think the risk that this branch introduces new Tor leaks is very low but still, this is worrying.

I made 7ff6c1d2ff6a065a4d492f9b63ff198308a91e8b (so I can inspect pcap files) and started a run locally. I'm assuming this is not a regression, but we'll see.

  • Electrum, as expected

Ack!

  • Most of features/torified_gnupg.feature failed; it may be that my test system has trouble connecting to keyservers today.

Same for me, but it works when I test manually (so we're good), so I guess it's the onion redirection from our test network to the real Tor network (chutney_onionservice_redir() etc).

anonym, I'll let you make the go/no-go decision. Either way, I don't think we should delay 3.14.1 due to this ticket so I'm not going to re-run failing scenarios. I'm busy elsewhere anyway.

I'm merging this now so I can proceed with the 3.14.1 release, but might return here (possibly reverting this merge) if my findings for the leaks are bad.

#11 Updated by anonym 8 months ago

anonym wrote:

intrigeri wrote:

Full test suite run locally passed except:

  • #16825 made 11 scenarios fail their After hook which checks for Tor leaks; I think the risk that this branch introduces new Tor leaks is very low but still, this is worrying.

I made 7ff6c1d2ff6a065a4d492f9b63ff198308a91e8b (so I can inspect pcap files) and started a run locally. I'm assuming this is not a regression, but we'll see.

Turns out packetfu cannot parse RARP packets and this causes the issue.

#12 Updated by anonym 8 months ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF