Project

General

Profile

Bug #16817

Bug #16281: Update the test suite for Buster

Emergency shutdown automated tests on Buster often fail to notice that memory wipe was completed

Added by intrigeri 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
Test suite
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
test/16817-emergency-shutdown
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I see lots of "FindFailed: can not find MemoryWipeCompleted.png" while the video shows that the expected message was displayed (so I have a doubt wrt. the image update in 56f58e34d2bca109dc2f7d2467d2bc1364732355).


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 42a8651f (diff)
Added by intrigeri 5 months ago

Revert "Update MemoryWipeCompleted.png" (refs: #16817)

I see lots of "FindFailed: can not find MemoryWipeCompleted.png" while the video
shows that the expected message was displayed. And indeed, the candidates saved
by Sikuli when it does manage to find that picture look more like what we have
on our 3.x branches, which suggests that
56f58e34d2bca109dc2f7d2467d2bc1364732355 was perhaps only needed
temporarily last month, perhaps due to #16743.

This reverts commit 56f58e34d2bca109dc2f7d2467d2bc1364732355.

Revision 9858dc2e
Added by intrigeri 5 months ago

Merge branch 'test/16817-emergency-shutdown' into feature/buster

Fix-committed: #16817

History

#1 Updated by intrigeri 5 months ago

(I won't file tickets for every Buster test suite problem you surely know about already, but I need to at least track those that block the first beta.)

#2 Updated by intrigeri 5 months ago

#3 Updated by intrigeri 5 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri

And indeed, https://jenkins.tails.boum.org/view/RM/job/test_Tails_ISO_feature-buster/212/artifact/build-artifacts/sikuli_candidates/MemoryWipeCompleted.png looks more like what we have on our 3.x branches. I'm starting to suspect that 56f58e34d2bca109dc2f7d2467d2bc1364732355 was only needed due to #16743 and now breaks stuff.

#4 Updated by intrigeri 5 months ago

  • Feature Branch set to test/16817-emergency-shutdown

#5 Updated by intrigeri 5 months ago

features/emergency_shutdown.feature passes for me locally on this branch. Let's see what Jenkins thinks and especially, check that sikuli does not need to do fuzzy matching to find the picture.

#6 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)

intrigeri wrote:

features/emergency_shutdown.feature passes for me locally on this branch. Let's see what Jenkins thinks

That feature passed twice on https://jenkins.tails.boum.org/view/Tails_ISO/job/test_Tails_ISO_test-16817-emergency-shutdown/.

and especially, check that sikuli does not need to do fuzzy matching to find the picture.

No MemoryWipeCompleted.png in https://jenkins.tails.boum.org/view/Tails_ISO/job/test_Tails_ISO_test-16817-emergency-shutdown/1/artifact/build-artifacts/sikuli_candidates/ nor https://jenkins.tails.boum.org/view/Tails_ISO/job/test_Tails_ISO_test-16817-emergency-shutdown/2/artifact/build-artifacts/sikuli_candidates/.

So I think my hypothesis above this correct and this branch is the right thing to do.

#7 Updated by hefee 5 months ago

  • Assignee set to hefee

#8 Updated by hefee 5 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from hefee to intrigeri

Go ahaed, this sounds logic for me.

#9 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#10 Updated by intrigeri 5 months ago

  • Status changed from Fix committed to Resolved
  • % Done changed from 100 to 0

Also available in: Atom PDF