Project

General

Profile

Bug #16802

The colors of the "Screen Locker" dialog don't have enough contrast to be accessible

Added by sajolida about 1 month ago. Updated 22 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Accessibility
Target version:
Start date:
Due date:
% Done:

100%

Feature Branch:
bugfix/16802-screen-locker-dim-labels
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

As per the WebAIM Color Contrast Checker: https://webaim.org/resources/contrastchecker/

See screenshots in attachment.

Isn't there a safe default color in GNOME?

screen-locker.png View (10.7 KB) sajolida, 06/12/2019 02:01 PM

contract-checker.png View (86.7 KB) sajolida, 06/12/2019 02:01 PM

tails-screen-locker-no-dim-labels.png View (10.4 KB) segfault, 06/17/2019 11:03 AM

Screenshot from 2019-06-18 14-56-58.png View (51.4 KB) segfault, 06/18/2019 01:00 PM

Associated revisions

Revision 6ed8a433 (diff)
Added by segfault 29 days ago

tails-screen-locker: Don't use dim-label style class (refs: #16802)

Revision e54e8f78
Added by intrigeri 24 days ago

Merge remote-tracking branch 'origin/bugfix/16802-screen-locker-dim-labels' into stable

Fix-committed: #16802

History

#1 Updated by intrigeri 29 days ago

Indeed, there's something wrong (tested on feature/buster, not in 3.x). I can't find any other piece of UI that's affected so I wonder if the GTK bits of config/chroot_local-includes/usr/local/bin/tails-screen-locker have a bug that causes this. @segfault?

#2 Updated by segfault 29 days ago

intrigeri wrote:

Indeed, there's something wrong (tested on feature/buster, not in 3.x). I can't find any other piece of UI that's affected so I wonder if the GTK bits of config/chroot_local-includes/usr/local/bin/tails-screen-locker have a bug that causes this. @segfault?

I don't see a bug here. In the tails-screen-locker code, the GTK label style dim-label is applied to the labels, similar to many other labels in GNOME apps (e.g. Files and Disks). If you think that's an issue, the fix is easy. See attached what the dialog looks like without the dim style.

@sajolida: Do you prefer the style in the screenshot?

#3 Updated by sajolida 29 days ago

  • Assignee set to segfault

After a quick search I couldn't find guidelines or semantic for "dim-label" in GTK, but according to the meaning of "dim" in English, I guess that these are meant to be use in place where labels are actually meant to be not-so-accessible in colors: deactivated options and such.

So yes, please always use default "non-dim" label whenever we want our labels to be easy to read.

#4 Updated by segfault 28 days ago

sajolida wrote:

After a quick search I couldn't find guidelines or semantic for "dim-label" in GTK, but according to the meaning of "dim" in English, I guess that these are meant to be use in place where labels are actually meant to be not-so-accessible in colors: deactivated options and such.

Like I wrote above, the style is actually used quite frequently in GNOME apps. Also for description labels. See for example the attached screenshot of a GNOME settings page.

So yes, please always use default "non-dim" label whenever we want our labels to be easy to read.

I will change it for the screen locker.

#5 Updated by segfault 28 days ago

  • Status changed from Confirmed to In Progress

#6 Updated by segfault 28 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (segfault)
  • Target version set to Tails_3.15
  • % Done changed from 0 to 50
  • Feature Branch set to bugfix/16802-screen-locker-dim-labels

#7 Updated by hefee 27 days ago

  • Assignee set to hefee

#8 Updated by hefee 27 days ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from hefee to segfault

Code change looks fine -> review passes. As you already attached screenshots, no need to spin up a iso.

You can merge.

#9 Updated by sajolida 26 days ago

Like I wrote above, the style is actually used quite frequently in GNOME apps. Also for description labels. See for example the attached screenshot of a GNOME settings page.

Sorry for reading your previous comment to fast. Actually, it's already the case in Tails 3.14. But it seems like the contrast got a tiny be worse with the update to Buster (2.95:1 became 2.8). Meh!

#10 Updated by intrigeri 24 days ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from segfault to intrigeri
  • Target version changed from Tails_3.15 to Tails_3.14.2

#11 Updated by intrigeri 24 days ago

  • Status changed from Needs Validation to Fix committed
  • % Done changed from 50 to 100

#12 Updated by intrigeri 24 days ago

  • Assignee deleted (intrigeri)

#13 Updated by anonym 22 days ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF