Project

General

Profile

Bug #16800

"Question mark" instead of "book" icon for "Tails documentation" launcher on the desktop

Added by sajolida 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/32, bugfix/misc-buster+force-all-tests
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

In bc022ef71e.

How is that?

(But I appreciate that the buggy wrapping of "Tails / documentati / on" has been fixed :)


Related issues

Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 81a939d9 (diff)
Added by intrigeri 2 months ago

Use the same icon for Tails Documentation in the Applications menu as on te Desktop (refs: #16800)

Revision 1adb8d4f
Added by intrigeri about 2 months ago

Merge branch 'bugfix/misc-buster+force-all-tests' into devel (Closes: #16800, #16945)

History

#1 Updated by intrigeri 4 months ago

  • Status changed from New to Confirmed

How is that?

Context: we now need SVG icons.

f351ab636e7c39da3036b0d1cfd20c00eea92406 configured this launcher to use the tails-help icon. It seems this icon does not exist. hefee, do you recall what was the idea?

I see no scalable (SVG) version of this "book" icon but there's /usr/share/icons/Adwaita/scalable/categories/system-help-symbolic.svg, that is the standard GNOME help icon, which we could use (probably with something like Icon=system-help-symbolic). @sajolida, would this icon be fine by you?

Here as well, given the last decision wrt. desktop icons (keep them as long as it's not too costly to maintain), let's aim for a cheap solution :)

#2 Updated by sajolida 4 months ago

GNOME icons has different "flavors" and the symbolic flavor is the 1-color flavor and is meant to be use only in some places. So far our Applications menu and desktop have used the fullcolor flavor and I'd rather stick to that if it only means adding some SVG to our source tree.

Here is the upstream source for the fullcolor version:

https://gitlab.gnome.org/GNOME/adwaita-icon-theme/blob/master/src/fullcolor/legacy/system-help.svg

If it needs some SVG manipulation (like cropping to only the size that we want), I'm happy to do that as it'll take me no time.

#3 Updated by hefee 4 months ago

  • Assignee set to hefee

#4 Updated by hefee 4 months ago

intrigeri wrote:

How is that?

Context: we now need SVG icons.

@intrigeri not necessarily, but if we only have 48x48 the icons looks very blury and visibly arkward.

f351ab636e7c39da3036b0d1cfd20c00eea92406 configured this launcher to use the tails-help icon. It seems this icon does not exist. hefee, do you recall what was the idea?

the icon is shipped with tails-greeter package. The idea from kibi and me was to use the same icon for tails help everywhere, so users will recognize this icon.

sajolida wrote:

GNOME icons has different "flavors" and the symbolic flavor is the 1-color flavor and is meant to be use only in some places. So far our Applications menu and desktop have used the fullcolor flavor and I'd rather stick to that if it only means adding some SVG to our source tree.

Here is the upstream source for the fullcolor version:

https://gitlab.gnome.org/GNOME/adwaita-icon-theme/blob/master/src/fullcolor/legacy/system-help.svg

If it needs some SVG manipulation (like cropping to only the size that we want), I'm happy to do that as it'll take me no time.

sajolida No cropping is needed for svg, as this will be scaled correctly.
We just need to copy this svg to @config/chroot_local-includes/usr/share/icons/hicolor/scalable/
, update the name and we are done.

#5 Updated by hefee 4 months ago

  • Assignee deleted (hefee)

#6 Updated by intrigeri 4 months ago

f351ab636e7c39da3036b0d1cfd20c00eea92406 configured this launcher to use the tails-help icon. It seems this icon does not exist. hefee, do you recall what was the idea?

the icon is shipped with tails-greeter package

My bad! /me hides :)

The idea from kibi and me was to use the same icon for tails help everywhere, so users will recognize this icon.

So next step is: @sajolida tells us whether he prefers consistency+change (i.e. keep using this "question mark" icon on Buster) or inconsistency but no change (reverting to the book icon).

#7 Updated by sajolida 4 months ago

The idea from kibi and me was to use the same icon for tails help everywhere, so users will recognize this icon.

Oooook, I appreciate the initiative!

Though I personally prefer the previous icon:

  • The question mark is now blue on blue with little contrast. But sure,
    it's BIG!
  • I never considered the question mark icon that we used in different
    apps (Tails Greeter) as the icon for the launcher but rather as a very
    common was of providing contextual help in applications and websites.
  • I find the book more colorful and pretty.

That said, I don't know whether your hypothesis is valid and whether it
will make it easier for users to relate it to the question mark icon in
our interfaces.

So I'll leave it up to your personal taste :)

#8 Updated by hefee 4 months ago

  • Status changed from Confirmed to Rejected

After a short discussion with intrigeri:
Keeping the question mark aka status quo is the cheapest solution for us and a big question mark labeled "Tails documentation" should be good enough.

#9 Updated by sajolida 4 months ago

  • Status changed from Rejected to In Progress

Now the icon on the desktop is inconsistent with the logo in the Applications menu (Applications → Tails → Tails documentation).

Can you fix that?

#10 Updated by intrigeri 4 months ago

Now the icon on the desktop is inconsistent with the logo in the Applications menu (Applications → Tails → Tails documentation).

Good catch!

Can you fix that?

Presumably setting Icon=tails-help in config/chroot_local-includes/usr/share/applications/tails-documentation.desktop.in should be enough.

#11 Updated by intrigeri 2 months ago

  • Priority changed from Normal to Elevated

#12 Updated by intrigeri 2 months ago

  • Assignee set to intrigeri

#13 Updated by intrigeri 2 months ago

  • Feature Branch set to bugfix/misc-buster

#14 Updated by intrigeri 2 months ago

  • Feature Branch changed from bugfix/misc-buster to bugfix/misc-buster+force-all-tests

#15 Updated by intrigeri 2 months ago

  • Feature Branch changed from bugfix/misc-buster+force-all-tests to https://salsa.debian.org/tails-team/tails/merge_requests/32, bugfix/misc-buster+force-all-tests

#16 Updated by intrigeri 2 months ago

Fixed on the topic branch that I'll submit once I've validated its other changes.

#17 Updated by intrigeri 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to anonym

Same as #16945.

#18 Updated by intrigeri 2 months ago

#19 Updated by anonym about 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from anonym to intrigeri

I built an image with 81a939d9e6f576ed97730d0c2546c27d71474f1f but the icon is still a question mark.

#20 Updated by intrigeri about 2 months ago

  • Status changed from In Progress to Needs Validation
  • Assignee changed from intrigeri to anonym

I built an image with 81a939d9e6f576ed97730d0c2546c27d71474f1f but the icon is still a question mark.

That's intended. What this branch does is: have the launcher in the apps menu be a question mark too, just like the one on the desktop.
If you're interested in the details, see the discussion above :)

#21 Updated by intrigeri about 2 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

#22 Updated by intrigeri about 2 months ago

  • % Done changed from 100 to 0

anonym ACK'ed this branch in a private email so I've merged it.

Also available in: Atom PDF